Sign in with
Sign up | Sign in
Your question

XPC hangs at Verifying DMI Pool with RAID HD

Last response: in Systems
Share
July 1, 2012 4:41:36 AM

Hey all,

I've got a real noodle scratcher of a spatchala of a problem as Ned Flanders would say. I haven't made any changes to my system as of late (BTW, here are the specs:

Shuttle XPC
-AMD 3200+ CPU

-2 GB DDR RAM

-ATAPI IDE CD/DVD-RW
-SATA 160 GB HD configured in a RAID Array (don't ask me why, this is how the unit was shipped and there is NO WAY there is enough room for a seond SATA HD unless you remove the CD/DVD-ROM drive.

-AGP Radeon HD card (can't remember the model # off hand, I'm sitting at another location recalling all these stats from my memory)

-4 USB Ports
-One non-working integrated Ethernet port

-Realtek Integrated HD Audio
-250w-400w PSU custom made by Shuttle (again, can't remember the exact wattage but I believe that has little to do with the problem at hand)

When this issue first started occurring I used my trusty Acronis boot disk to reload a recent backup of WinXP from my trusty Seagate FreeAgent USB Drive. My HD is partitioned into 5 pieces:

One 40 GB partition which is for exclusively Windows XP

One 40 GB partition which is for My Documents folder

One 40 GB partition which is strictly for games
and you get the idea

Anyways, re-imaging the windows partition did nothing and I still get the same message "Verifying DMI Pool..."
although sometimes it does say UPDATE SUCCESS and then freezes. Progress? Hah.
Also, strangely enough when I disconnect and reconnect the CD/DVD-ROM drive after Verifying DMI Pool it will go straight to "Boot from CD....." and then get stuck there unless of course, I obviously insert a bootable disc.

Here's what I've done so far besides needlessly re-imaging my Windisk partition:


-Removed the CDROM completely so that only the SATA RAID Array would load - still same issue

-Changed the jumpers on the CDROM from SLAVE to MASTER and reconnected the CD/DVD drive - same issue

-Made sure that all connectors going to and from the MB to the SATA drive were connected and firm along with
the SATA power adapter - the SATA drive also has a spot for old style 4 pronged power adapters but I haven't tried that.

-Removed the old CD/DVD-ROM drive completely and swapped it out for an ASUS QuietTrack Burner with the
jumper set SLAVE - same issue (also tried MASTER configuration, no luck)


I also constantly check the BIOS to ensure the CD-ROM drives were recognized, they both were after each time I swapped or made changes. However the SATA drive is NEVER recognized by the BIOS (this is how the XPC has ALWAYS been since I purchased it 5-6 years a go - the IDE DRIVE 1 or IDE DRIVE 2 is always listed as the
CD/DVD-ROM drive.)

You can access the RAID Array configuration by pressing a certain function key before the DMI Pool hang occurs, but this offers little to nothing.

Also, I should note that the CMOS battery is on it's way out because I keep receiving "CMOS Checksum Error - Press F1 to Continue or DEL to Fix" which brings me to the BIOS and I have to set the time/date correctly each time this happens. This is more of a nuisance then anything else but if this is causing the DMI Pool hang I would gladly replace the battery .

So that's the skinny? Anyone have any ideas or suggestions? I haven't tried resetting the BIOS to default settings yet, I guess that would be next.

P.S. Because of the ridiculous compact size of the XPC it is extremely hard to work in so if you plan on having me tear out the SATA HD please give me ample reason as to how it could fix this issue.

Thanks in advance friends!


-DDM
July 1, 2012 4:59:59 AM

make sure the HDD is the first boot device in BIOS

set the HDD jumper to master , and assuming the cd is on the IDE ribbon cable make sure its set to slave

if it still wont boot then most likely either the cable is faulty [ even a tight bend can stop data ] or the hard drive is dead

BIOS may verify its death if its not listed as a boot device

Assuming you are running windows XP? If you are you may be able to save a partially damaged HDD / windows installation by doing a repair install
http://www.michaelstevenstech.com/XPrepairinstall.htm
but this is less likely than the HDD being dead
July 1, 2012 1:24:06 PM

Sata disk drive will not have jumpers for master/slave.

Failing CMOS battery will change BIOS settings as well as the date/time. Replace the battery ($2 at grocery store), boot into BIOS and set BIOS back to factory defaults. SAVE. exit. This will give you a stable platform to work from. (If it fixes the problem, great, but that's not why you are doing it).

Verifying DMI Pool: that checking the IO config reports to the BIOS. Hanging there might be the disk drive, opticals, etc.

You said "I also constantly check the BIOS to ensure the CD-ROM drives were recognized, they both were " Try removing power and SIGNAL cables from both optical drives. Boot in that config. Does is hang or boot?

Keeping the opticals disconnectde at power and signal, Remove power and signal cable from the hard drive. Boot. Did you get the "no boot device found" message or did you get the hang. Sometimes (incredibly) the last BIOS message is the last thing that worked OK rather than the step about to be tried. This means you have no clue what failed and need to debug. The rest of this post assumes that you got the "no boot drive" message instead of a hang. Post if that is not true.

Power up system. Plug in the sata drive, leave the opticals out. Did the hard drive spin up? Is it detected by BIOS? If not re-seat the power and SATA cable at both ends even though you've done it before. Your hard drive needs to spin up and be recognized to be able to run diagnostics on it. IF it can't be recognize buy new drive. From your post above I'm expecting it to be recognized.

If drive is detected download a boot-able diagnostic from the drive manufacturer. BIOS will give you model number. Google for download. Run diagnostic. Disk ok?

Disk Failed: Replacing the hard drive might be a challenge given small case, but it is one of the easier tasks in PC repair. Post if your drive won't spin or be detected.

stopping here and seeing what results you get when you try things.
July 8, 2012 4:16:25 AM


Here is what has been done since I posted last. A good friend of mine came over to assist with the problem and brought another SATA HD with him. (He told me he wasn't sure if it was working or not but I figured it
couldn't hurt to throw it in there)

Swapped my current SATA hard drive for the other SATA drive my friend brought and connected it to SATA Data/power cables,

Connected optical drive as well, booted XPC and still got the "hang" on Verifying DMI Pool...

Disconnected data/power from optical drive and disconnected data/power cables from new SATA HD. Started XPC again and got PAST Verifying DMI Pool message to this:

NVIDIA Boot Agent 191.0304
Copyright (C) 2001 NVIDIA Corporation
Copyright (C) 1997-2000 Intel Corporation
PXE-E61: Media Test Failure, check cable
PXE-M0F: Exiting NVIDIA Boot Agent
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

**Now my friends SATA HD probably didn't have an OS installed which is why the INSERT SYSTEM DISK message occurred**

Shutdown XPC. Noticed that there were two SATA Data connectors on the Shuttle mobo. I unplugged the SATA Data cable from the 1st SATA connector and plugged the HD into the second SATA Data connector on the mobo. Plugged the power to the optical drive back in and left optical data cable unplugged. Restarted XPC and it still froze on Verifying DMI Pool. I restarted into Shuttle XPC BIOS, went to Integrated Peripherals and selected Onboard PCI Device. I then DISABLED the "Sil3512A
SATA Raid ROM" (which I assume is for the RAID Array that is non-existant in my XPC) and saved the settings to CMOS and rebooted.

Now, this time it DID NOT hang on Verifying DMI Pool and instead gave me the same message when the SATA HD wasn't
connected at all:


NVIDIA Boot Agent 191.0304
Copyright (C) 2001 NVIDIA Corporation
Copyright (C) 1997-2000 Intel Corporation
PXE-E61: Media Test Failure, check cable
PXE-M0F: Exiting NVIDIA Boot Agent
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

I highly doubt that I have two bad SATA HD's on my hands (my friends drive and the original that came installed in the
Shuttle). Perhaps disabling the RAID Array within the BIOS will get my factory SATA drive working again. There was no
operating system installed on my friends HD otherwise it may have booted.

If I still get the same issue or some other error with my original SATA HD installed then I guess I'll try replacing the SATA Data cable with a new one and if that fails well then maybe i'll just say F*** it and install a IDE HD,
purcahse a SATA --> USB cable and transfer all my data off my HD to the new IDE drive. I do have a few IDE drives sitting around that could be put to better use.

Also, I noticed that my Shuttle Western Digital 200GB Sata Drive has a jumper pin on the back. As it reads from the manufacturers label on the front:

Jumpered Pins 1 and 2 disable SSC (Spread Spectrum Clocking)
Jumpered Pins 3 and 4 enable PM2 (Power-Up in Standby)

Currently, the HD is set for disabling SSC....?

Anyways, it's been a hell of a night working inside this stupid tiny little case and I'm calling it quits for tonight. I think it will be a lot easier purchasing a SATA --> USB cable and plugging my Shuttle SATA drive into one of my working PC's and see if it fires up then to continue farting around in a PC case the size of a tampoon. At least then I'll know the HD isn't shot and I can still retrieve my data. If anyone has anything further relevant to add or something easy that I haven't tried yet feel free to post!

Oh yea, don't know if I mentioned it but I did try resetting all BIOS settings to default in almost every drive configuration I had this PC on.

-db
!