Sign in with
Sign up | Sign in
Your question
Closed

After installing 12.4 drivers cccc says 11.5 is installed

Last response: in Graphics & Displays
Share
May 9, 2012 5:15:00 AM

Hey all,


I recently tried updating my drivers from 12.3 to 12.4. I did my normal thing, I uninstalled it with the "Express uninstall all ATI software" and uninstalled drivers from Device manager (with the uninstall software button checked). Restarted then installed new drivers. When I check the CCC it says I have 11.5 installed. I tried uninstalling a million times in different ways, not restarting the computer and restarting the computer, not uninstalling old drivers and windows updates but nothing seems to work. Anyone else running into this issue? If it helps I'm running CrossfireX with 2 Radeon 5870's. Thanks.
May 9, 2012 9:32:22 AM

I been seeing this around in forums all over the web, Uninstall CCC and video driver with like CCleaner and see if it works, Others will say to download another program to uninstall the driver within safemode (probably a better option)
Score
0
May 10, 2012 6:14:20 AM

i've had this problem too. i did a reformat and havent been able to install 12.4 since. it always tells me 11.5

i've reformatted several times (just out of frustration) and it doesn't seem to help so i'm not sure if uninstalling it helps at all :/ 

out of curiosity are you running crossfire or a standalone card?

edit: sorry, yea you are. idk. i've even tried uninstalling one card to see if it would help. never had this issue with my stand alone 6770
Score
0
Related resources
May 10, 2012 6:49:39 AM

I was about to start a new thread with this issue. Mine is slightly different. I recently upgraded from vista to windows 7 when i bought my new 3570k cpu, sabertooth z77 mobo, and new ram. When I try to update to 12.4 through Catalyst Control Centre for my 6870 drivers, it keeps showing me I have version 11.6.

I've done what you said, uninstalled old drivers, reinstalled new ones, restarted, not restarted etc etc.
It sucks as I can't even play BF3 because it says I need to update my drivers and when I try it DOESN'T WORK!!

Anyone know what is causing this issue?
Score
0
May 10, 2012 10:09:10 PM

Yeah I've tried CCleaner and Driver Sweeper and now instead of showing 11.5 it show "AMD Catalyst Not Available" lol as if I don't have the driver installed. It feels like everythings normal but it'll a little unsettling not knowing right now what version I have installed, if at all. I plan doing a clean install of Windows 7 this weekend but from what I've read above it doesn;t help! I'll let you know my outcome, but hopefully it isn't a hardware compatibility issue.

I plan on upgrading to Ivy Bridge some time this summer since I'm still using 1st generation i7 and I'd like to see the benefits in Autodesk rendering times. Let me know how you guys turn out with this problem!!
Score
0
May 10, 2012 11:46:52 PM

if it is hardware i think it has to do with crossfire. when you reformat try unplugging your second card until you have it updated maybe?
idk why that would matter but its the only thing i've changed and its when my problems started happening
Score
0
May 11, 2012 10:01:35 PM

I have the same issue and I do not have 2 cards crossfired not sure what the issue is.
Score
0

Best solution

May 16, 2012 3:08:09 AM

emailed AMD

here is their response

Response and Service Request History:

Thank you for contacting AMD

I understand that you installed 12.4 but the system information has not changed to 12.4 instead it states that it’s running Catalyst version 11.5. If I have missed any critical information please let me know as my suggestions may change.

It has been a noted issue that when you update to Catalyst 12.4 it does not change the system information. Our Catalyst engineering team is currently working on it and there should be a fix for it in 12.5. If you went through the 12.4 installation and it was all successful it means that the system is using the 12.4 drivers just that the system information did not change. If you do need a current version number in the system information to play games or to run a certain application my recommendation is to install 12.3 for now till 12.5 is released.

Windows 7 64bit previous drivers:

http://support.amd.com/us/gpudownload/windows/previous/...

In order to update this service request, please respond, leaving the service request reference intact.

Best regards,

AMD Global Customer Care
Share
May 16, 2012 5:34:45 PM

Hmm thanks for posting this, I guess I'll just have to wait til they clean up their mess lol Im not doing much gaming now anyway. Good luck all.
Score
0
May 22, 2012 8:27:11 PM

cheers just seen same problem on my system hope they hurry up
Score
0
May 23, 2012 1:59:53 PM

Mine says 11.12. But I am running 12.4. If I look at the driver date is device manager, It says "4/5/2012". Oh well, games work still, so I don't mind.
Score
0
May 23, 2012 2:12:54 PM

That Happen to me too!!!! But I got it resolved. Don't download the driver at the AMD site. Download it on the other like filehippo or something? I forgot where to download it but I just search "ATI 12.4 Free Download" then choose other sites NOT THE AMD. Don't worry It's safe and AMD can still detect it normally :D 
Score
0
May 24, 2012 2:54:57 AM

I am having the same problem. I wiped 12.1 clean of my system and installed 12.4, but every time I start my computer I get a pop up saying I have 12.1 installed and need to upgrade.

I tried reinstalling 12.4 again but I still get the same pop up.

I hope it's not affecting my Diablo III performance.
Score
0
June 3, 2012 2:29:43 AM

Best answer selected by kickflipper1087.
Score
0
June 3, 2012 5:19:15 AM

This is really frustrating for online gaming yet alone browsing the internet. I recently bought a setup with a 6970 and my gpu bogs out and comes back fairly often. I know it isn't overheating as it is a good rig. Good to see that other people got the 11.5 error like I did.

I took my build to my supplier and he updated mobo bios and set it to 12.3... guess what... still crashing. I want a fix soon.
Score
0
a b \ Driver
June 3, 2012 9:51:22 AM

This topic has been closed by Maziar
Score
0
!