Sign in with
Sign up | Sign in
Your question

Radeon 7970 no longer reporting 3 gig RAM, only 1 gig?

Tags:
  • Radeon
  • RAM
  • Graphics
Last response: in Graphics & Displays
Share
May 10, 2012 6:45:10 AM

I was having some of the same 12.4 issues as other posters. I had 12.3, tried to install 12.4 and it still reported 12.3. I left it alone and then today the auto-updater came on for 12.4 again, so I let it auto-update to see if that worked. Still reported 12.3 but it seemed to have done more damage because I believe my 7970 is only using 1 gig ram now.

When I look at the hardware section of Catalyst, it says 3 gig RAM but the System Information button only says 1 GIG Adapter RAM available. Also, I have been playing Crysis before this issue on max everything, hi-res textures, increase draw distance etc and it dips to 25 fps sometimes but little texture popin. Now after this problem, I get 40-50 almost everywhere + texture pop-in. Plus the r_displayinfo 1 says MEM = 1000K, though admittedly I don't recall what that said before.

What is going on? How can I fix this problem? Argh. I tried uninstalling the AMD Display Driver and Catalyst Center using the Uninstall routine from the 12.4 drivers (launched drivers, hit uninstall, hit custom, and selected the AMD Display DRiver and Catalyst Center). Then reinstalled 12.4 and the problem remains even after reboot.

Help please.

Thanks!

More about : radeon 7970 longer reporting gig ram gig

May 10, 2012 7:58:42 AM

UPDATE: I ran CPU-Z to see what it reported about my video RAM and it also reports that I have just 1 GIG of Adapter RAM available, despite being a 7970 with 3 GIGs of RAM.

Could the drivers have broken my card somehow or is this likely just some weird driver issue.

That I can't seem to fix. Sigh. Anyone?
m
0
l
May 10, 2012 8:05:31 AM

okay, that reports that I have

Total Available Graphics Memory: 6891 MB
Dedicated Video Memory: 3072 MB
System Video Memory: 0 MB
Shared System Memory: 3819 MB

So that seems to be reporting correctly, right?

However, why are other things seemingly reporting incorrectly?

thanks for answering btw.
m
0
l
Related resources
May 10, 2012 8:07:56 AM

I understand, but as I said in my first post, I think games are having a problem too as I believe Crysis is only using 1 GIG of video ram instead of 3.

I mean it still runs fine, so I can't complain that much but I just am annoyed that installing drivers seems to have caused this issue.
m
0
l
May 10, 2012 11:38:54 AM

Okay, thanks I'll get that program, though I suspect it's going to tell me that the game is only using 1 GIG of my RAM for some reason.

Can I try rolling back the driver? Do you just accomplish that through:

Control Panel, Hardware, Device Manager, Display Adapter, Driver? Hit the Roll Back button and follow the prompts? Figure I could try rolling back to 12.3 or 12.2 if it is easy enough. Also I imagine 12.5 might fix it since a lot of ppl seem to be having the 12.4 misreporting problem.

Anyone else have any thoughts too?

m
0
l
May 10, 2012 11:44:42 AM

Oh yikes, good point.

Just for the sake of argument, what are you going to say next if Afterburner reports that the game is only using 1 GIG :) 
m
0
l
!