Sign in with
Sign up | Sign in
Your question

New power supply same problem

Last response: in Components
Share
November 14, 2012 4:22:50 AM

many of you may have seen my earlier post about power supplies keep dying. well i got my new one today and it lasted 30 minutes. it's a xfx 850w silver plus 70amp single rail. what is going on here. i dont understand this. i have went thru 5 power supplies in 3 years. so what is the problem? i check the plug outlet it is fine. i have a surge protector. it's a amd quad core 9550 2.20 agena phenom with a pci sound card 3 hard drives 1 dvd burner and a asus gts 450. i am at wits end with this. this new power supply that just died cost me $165 i need an answer for this... please help i can reseat the video card and occasionally it will work but i tried stress tested and they all caused automatic reboots i used furmark and prime 95 and got automatic reboots. i don't know what to do anymore...

More about : power supply problem

a b ) Power supply
November 14, 2012 4:29:32 AM

You shouldn't need anywhere close to that much power for a system like that.

Can't you return the PSU for that $165?

What country are you in? It might be that a US power supply made for 110v isn't playing nicely. (I know a lot of them fry, with Britain's 220v wall plugs.)
November 14, 2012 4:31:56 AM

RMA the power supply. Sounds like there is another problem. As for your benchmarking, if it always fails, something isn't right. Try one stick of memory, one hard drive, you vga and nothing else. Could be a bad motherboard though and maybe that is killing your psus. As for a new power supply, get a Seasonic.
November 14, 2012 7:57:56 AM

it's just a disaster. i think i am going to rma the power supply and just put the new one in a another computer i have and move my hard drives and stuff to it and be done with this one. xfx is supposed to be made by seasonic. i have lost all faith in getting this computer to work. that and i don't think companies make things like they used too. i do know i no longer have working on board video for some reason. i have to have pci express card in to post.
!