Front USB ports not working

I bought a NZXT phantom case and hooked it up about six months ago. I recently reinstalled windows 7 and now, the usb no longer works. I've reassembled the case yet I can't find anything that's wrong. It's all connected and I installed all the needed usb updates. Does anyone have a clue what's going on?
5 answers Last reply
More about front ports working
  1. Brett928S2 said:
    Hi :)

    If its JUST the front ones, check the cable to the motherboard...

    All the best Brett :)

    All checked. I plugged the cable into all 3 available slots.
  2. Hi :)

    If its JUST the front ones, check the cable to the motherboard...

    All the best Brett :)
  3. Khangirey said:
    All checked. I plugged the cable into all 3 available slots.


    Hi :)

    So IS IT just the fronts ? and if so are they usb2 or 3 ?

    All the best Brett :)
  4. Brett928S2 said:
    Hi :)

    So IS IT just the fronts ? and if so are they usb2 or 3 ?

    All the best Brett :)

    There is a 3.0 port but I don't have a connector on my motherboard so I leave it alone. I've been using 2.0 and what's bugging me isn't that it's not working, it's just that I've ran out of room, and it's either my headset or my flight stick that has to go.
  5. Khangirey said:
    There is a 3.0 port but I don't have a connector on my motherboard so I leave it alone. I've been using 2.0 and what's bugging me isn't that it's not working, it's just that I've ran out of room, and it's either my headset or my flight stick that has to go.



    Hi :)

    Well if you have to, buy a 7 port USB hub to plug in the back...they are cheap, my shops sell them for around £10, so you should be able to buy them cheap locally...

    All the best Brett :)
Ask a new question

Read More

Power Supplies Windows 7 Cases USB Components