Sign in with
Sign up | Sign in
Your question

Help! GTX680 and WoW Freezes

Last response: in Graphics & Displays
Share
May 13, 2012 2:32:27 AM

Hi There,

I just installed my Asus GTX680 and all appeared to be running smoothly. I entered one game (AION) and things look stellar; but when I entered WoW my screeen froze up in game right away. I tried my settings at Fair and its worked ok, but it seems when I hit "good" it freezes again. All Drivers are up to date, etc. so I am at a loss as to what the issue may be. Any thoughts/suggestions please?

More about : gtx680 wow freezes

a c 254 U Graphics card
a b Ý World of Warcraft
May 13, 2012 2:42:38 AM

Are there any updates for the game that have not been installed ? Do you have any other games to try? Do you have any other power connectors to swap out and try , the power supply that you have has 6 Pci-e connectors so you do have extras to try. Also make sure that you didn't plug in the 8 pin atx cpu power connector insetead of the pci-e connector.
m
0
l
a c 181 U Graphics card
May 13, 2012 3:17:29 AM

^+1
I have to ask this but are you checking your temps? For both your GPU and CPU?
m
0
l
Related resources
May 13, 2012 3:43:13 AM

Ty for the response. As I mentioned above, I tried AION and everything worked great and all settings were on High. FPS was easily over 60. WoW is up to date. The success i had playing Aion is what makes this so puzzling....especially as settings were all set at high...

As for the connectors, yes i do have the PCI-e connected and no option to "swap" connectors I dont think for the PCI-e.

@DM ...yes, I am monitoring my temps and they are Fine (gpu never got above 40 degrees C and same with my cpu cores) .....
m
0
l
a c 181 U Graphics card
May 14, 2012 12:48:14 AM

At least the Temps are ruled out. In the nVidia control panel under manage 3D settings and on program settings right under that is a drop down box look in there to see if the WOW is in there.

If it isn't then there is a little check box under the drop down. Un check it then click on the drop down box and go all the way to WOW and check that box. Once you do that you can controll the settings in the game.

You can try to turn off the AA or you can just read about everything in there and make adjustments or turn on or off things. If none of that has helped then try reinstalling the game and check the cache integrity of the game files in Steam.
m
0
l
!