Sign in with
Sign up | Sign in
Your question
Closed

Radeon 7670m

Last response: in Graphics & Displays
Share
May 13, 2012 4:04:55 AM

Hi i just bought an acer aspire 7750g-9810 and it has the switchable graphics. When i put it into high performance it uses the 7670m card. i try to play any game that uses opengl and then after two or three minutes of play it says "display driver has stopped working and recovered" i looked around online and people said that it could be the ram but i switched it out and it still said it. People also said it could be overheating but the temp only gets to 60 degrees Celsius.

P.S.
the games are
Skyrim
Fallout 3
Minecraft

More about : radeon 7670m

May 13, 2012 4:11:03 AM

you should try updating your graphics drivers at amd.com

good luck

edit: if amd doesn't have newer drivers (you can use their auto-detect feature) you can probably get them from Acer.
Score
0
May 13, 2012 4:12:27 AM

the card does not show up when i go to amd's website i had to get the driver from acer.
Score
0
Related resources
May 13, 2012 4:14:10 AM

So you have updated your drivers?

Also, you can use AMD's "auto-detect" feature.
Score
0
May 13, 2012 4:15:29 AM

yes i have updated them and the auto detect feature says that it cannot detect the card
Score
0
May 13, 2012 4:40:42 AM

thats weird. If drivers are up to date then it could be a faulty card. I would call Acer and see what they say.
Score
0
May 13, 2012 4:42:12 AM

Also make sure you reverse any changes you've made to the laptop (changing hardware) because that's grounds for Acer to terminate your warranty.
Score
0
May 17, 2012 5:34:03 AM

you are not alone. I bought a brand new Aspire 7750G-6645 with Dynamic Switchable Graphics - 7670M. I have the exact same problem. Pretty much any game if i tweak the settings. Lara Croft Guardian of Light on any settings, Dungeon Defenders on above medium, and I just tried Diablo3 and pretty much on all settings it blue screens. I got D3 to work with limited crashes on lowest settings, and maybe none now that i did full screen windowed mode. I got the same error ("display driver has stopped working and recovered") as you if i alt+tab to windows and close program before it gets a chance to go to blue screen.

It seems impossible to update the drivers for these. I have the most current ones from the Acer website but they are not current. Right now I have CCC 2011.1013.754.12275 and AMD Display Driver 8.901.4.0000. I've contacted both Acer and AMD with no response. Also have sought help on forums and my bluescreen log shows the ati sys file as the culprit of blue screen. Auto detect from the AMD/ATI site doesn't work, and i've tried to find drivers there (latest i've tried is 12-3_mobility_vista_win7_64_dd_ccc) but anything there hasn't worked. I've also tried leschat 12.3. I've followed the guides and have run Driver Sweeper and followed steps before installing drivers, but nothing works. What a waste buying this laptop if the video card isn't going to work correctly. I could've gotten something 100-200 cheaper if this is the performance i'm getting.

please let me know if you find any solution.
Score
0
May 17, 2012 6:58:36 AM

finally found drivers that i could install:

http://drivers.leshcatlabs.org/2012/05/15/catalyst-12-3...

so far i've only played Diablo3 on these drivers for abotu 20 minutes, but they were stable for 20 minutes on medium to high settings, whereas on lowest possible settings i'd get bluescreens every 5 minutes before.

FYI I installed 5/14 Catalyst 12.3 UP2 UnifL for Hybrid Graphics, which "includes config updates from 12.4 and 12.x":

5/4 Catalyst 12.4 WHQL UnifL for Hybrid Graphics:

Quote:
Main Changelog:
- Updated ATi Graphic Driver ( 04/05/2012, 8.961.0.0000 ).
- Includes Intel HD Graphics ( ver. 8.15.10.2559 ).
- Updated optional ATi HDMI driver ( ver. 7.12.0.7706 ).
- Includes DSE by Default.
- Updated YaD’s UnifL Cleaner ( ver. 2.1.1.0 ).

Minor Changelog:
- Refreshed look of UnifL package.
- Buttons placement reconsidered to more common allocation.
- Added support for Acer 7750G with AMD HD 7xxx series. <---------------------------
- Added support for HP Envy 17 – 3xxx series.
- Other Changes.
Score
0
Anonymous
a b U Graphics card
May 22, 2012 11:55:08 PM

hi guys

any solutions yet?

these are the combinations ,i have used to fix it

Not unlocked 1.20 bios and radeon driver 8.901.4.0 = flippingscreen,bluescreen
unlocked 1.17bios and radeon driver 8.901.4.0= flippingscreen,weird shapes in the game (bfp4f)
older bios (not sure which1) and radeon driver 8.901.4.0=radeon not usable
Not unlocked 1.20 bios and radeon driver from Catalyst 12.3 UP2 UnifL for Hybrid Graphics=game doesn't even start
unlocked 1.17bios and radeon driver from Catalyst 12.3 UP2 UnifL for Hybrid Graphics=the game exits while loading without any error or warning


i also installed chipset and intel gpu drivers.

i dont want to give up but it looks like i have tried everything ,what could help :D 

7750g is a big fail...

Score
0

Best solution

May 24, 2012 3:17:31 PM

i have about 35 hours of game time on diablo 3 right now. 1 crash about 5 hours in, turned down settings and after that no problems.

I'm using:
http://drivers.leshcatlabs.org/2012/05/15/catalyst-12-3...

Have never tried making changes to BIOS.

My suggestion is to go to leshcat's site and open a ticket and ask kindly for assistance. I agree 7750G is a fail, and i've given up on getting support from AMD/ATi or Acer.
Share
May 25, 2012 3:11:29 AM

thank you this works great
Score
0
May 25, 2012 3:11:42 AM

Best answer selected by Basty2168.
Score
0
a c 271 U Graphics card
July 22, 2012 5:41:28 AM

This topic has been closed by Mousemonkey
Score
0
!