12.3 wont update to 12.4 AMD radeon HD6950

As the title says, i first had 12.2 and then when i tried to update to 12.4 and when i installed it supposedly, i restarted my computer and such and then went to check if it updated. It said 12.3 and i tried it again and it said the same thing... any options on how to get it fully updated to 12.4?

thanks
8 answers Last reply
More about wont update radeon hd6950
  1. I have the same card in crossfire and tried updating from 12.3 to 12.4 to no avail even after going through a complete atiman uninstall. It says 12.3 in software.
  2. I have an ATI 5850 with this same issue (updating from 12.3 to 12.4). The card has been running hotter and performance on games have been bad.
  3. Have you tried completely uninstalling the catalyst control center and then installing 12.4?
  4. I have the same prob with my 6570 except mine says 11.5 and ive completely unistalled and ran driver sweeper in safe mode then reinstalled to no avail
  5. if you installed 12.4,12.4 is installed,even though ccc says otherwise,read somwhere its supposed to be fixed in 12.5.
  6. guys if u installed 12.4 its 12.4 ... don't worry that it shows the 12.3 its just a bug
  7. babarv2 said:
    guys if u installed 12.4 its 12.4 ... don't worry that it shows the 12.3 its just a bug

    yes this is true same happened here with my ati readon hd 4250
  8. Yes I have the same issue. I have a Gigabyte HD 6850 and it still says 12.3 in the Catalyst control center. I have tried updating it with the autoupdate and doing a complete uninstall of everything and fresh install from the AMD site and it still says 12.3. I guess I'll just wait until 12.5 and hopefully it will be fixed.
Ask a new question

Read More

Radeon AMD Graphics