Sign in with
Sign up | Sign in
Your question

Possible Processor Damage

Last response: in CPUs
Share
November 17, 2012 10:08:33 AM

Hello,
I have a old Desktop in my house, which was in my brother's workplace before. They sold it in an auction and i brought it home(just from curiosity!). It proved to be useful when my laptop broke down and i had to give it away for servicing. Anyways,The config is as followed:

Processor: Intel Pentium 4 HT 524
3.06 Ghz, 1MB L2 Cache
Board : Intel DG33FB (LGA775)
Ram : Transcend 2GB DDR2
HDD : Seagate Barracuda 80GB
PSU : Delux 450W(came with the casing)

Now, my friend also have similarly old PC with a Dual Core E2180 2.00 GHz processor. He wanted to try out my Processor, and i thought both are LGA775 so why not switch. so I took out the processor from my board and carried it to his house in a hard paper box. I put my P4 in his board and it worked fine, so i took his dual core and came back home.Now when i latched the dual core in my intel board, the PC wont start! when i press the power button the heat sink fan spins, the mouse LED lights up but nothing happens. I cant figure out what could have went wrong.mine worked on his board, then why wouldnt the dual core work in my board? I tried taking out the processor and putting it in a few times, but no results.could i have damaged the processor?

Any idea that what is the problem here?

-Thanks in Advance

More about : processor damage

a c 159 à CPUs
November 17, 2012 10:26:49 AM

No to damaging the cpu (very unlikely unless you used too much thermal paste). Those boards are picky about what cpus will work. You may need to reinstall your old p4 cpu and flash the bios.
November 17, 2012 10:43:35 AM

What do you mean by picky?
like I cant get the dual core to work on my board, just because it supports LGA775?
also,I never flashed the BIOS, how do i do that?
Related resources
a c 159 à CPUs
November 17, 2012 10:51:31 AM

Picky simply means the board only works with a select group of cpus. 775 was around for a long time; the first boards won't run any core2 duos even with a bios update. Intel kept changing the voltage specs for newer cpus, so older boards won't run them. Check Intel's website for bios updates and instructions on flashing the bios. Some flash utility programs work with usb flash drives. Some will run in windows, but may crash your board if there's a problem. Here's some links: http://www.intel.com/support/motherboards/desktop/sb/CS...
http://www.intel.com/p/en_US/support/highlights/dsktpbo...
November 17, 2012 10:51:53 AM

I would plug in your old CPU and see what BIOS revision you have. When the system was made the CPU range you are trying may not even have existed.

Having said that the board does seem to be quite flexible and supports a wide range processors which have been added on with newer BIOS updates. The E2180 should be working from version 0336.

If your BIOS is lower than that the newer processor might not be recognised. I would put your old processor in, update the BIOS and try again.

http://processormatch.intel.com/CompDB/SearchResult.asp...
!