Sign in with
Sign up | Sign in
Your question

Sapphire Radeon HD 5450 Video Card no signal error.

Last response: in Graphics & Displays
Share
May 16, 2012 3:10:32 PM

I ordered this card a few days ago. It arrived yesterday, and I didn't have time to install it until today. The problem is that any time it is connected to my computer I get a no signal error on my monitor, regardless of whether the VGA cable is connected to it or my onboard card and regardless of whether the onboard card is enabled or disabled.

I eventually got my original card working again by figuring out how to reenable it despite the picture going dead the instant Windows XP stops loading so I couldn't see anything but I haven't the slightest idea how to get this new card going on my machine.

I've tried disabling the onboard card, then installing the HD 5450 and making sure my VGA cable is connected to it and not the other card but then nothing happens. It just says no signal even though everything is firmly connected, which I've checked multiple times.

My computer is an eMachines T6520, all parts are standard except for the hard drive and of course the video card I'm trying to install. Everything I've seen says this is a compatible card and it should work.
May 16, 2012 3:26:59 PM

Is the power supply capable of powering a dedicated video card?
m
0
l
May 16, 2012 3:31:46 PM

Mine says 480 and 300(???) watts in different places. The card says 400 is recommended. I was told by some people here that it would work and this was a low power solution for my computer.

Edit: I'm also seeing in some other places that this card uses considerably less power than that, they just recommend a high end PSU to make absolutely certain the power needs are covered. There's another thread around here where someone has the exact same PSU and it works.
m
0
l
Related resources
May 16, 2012 4:46:34 PM

try connecting ur card to ur friends PC ...check if it's doa
m
0
l
May 16, 2012 9:24:40 PM

There aren't any other computers I can try it on right now. I just got it brand new so it had better work.

About the only option I can find that I haven't tried is disabling the onboard card in BIOS and see if that's it. But I can't find that option in Phoenix BIOS.
m
0
l
May 23, 2012 12:23:02 AM

The good news is the problem isn't as severe as I thought. The bad news is it took me a week to realize that and do something about it.

The problem was that my old motherboard and its PCI Express 1.0 slot could not recognize a 2.1 card. At least that's what I assume the problem is as when I returned it for a 2.0 card I was able to just plug it in, boot up, and have it work as expected. It's using the default drivers while I download and install the proper drivers but it is there and is working. As long as it works with the game I got it for all is well in the world.
m
0
l
May 23, 2012 1:36:27 PM

I had a MSI 5450 that I bought, and it needed a bios update or it would not give a signal with DVI, but it did with VGA or HDMI, kinda strange, try a different video output, if you use an adapter try a different 1.
m
0
l
May 25, 2012 11:18:58 AM

I was using a VGA cable. It's too late to try a different type as I've already returned it and resolved the problem.
m
0
l
!