Sign in with
Sign up | Sign in
Your question
Solved

Radeon hd 5830 screen tearing

Last response: in Graphics & Displays
Share
May 17, 2012 6:33:18 PM

Hello,

I have the above mentioned video card, and when I play games, I will occasionally 1 line or more (in cinematics usually). After research, I think this is referred to as screen tearing.

To attempt to fix this, I have run driver sweep to attempt to remove any other previous conflicting drivers, and completely removed and reinstalled updated drivers. The issue persists. I have read that this may also be a underpowered or failing psu issue. When I purchased this card, the sales guy also sold me this psu to power it. Could this be the problem, that my system is underpowered? I was considering upgrading my psu in the future anyway when I was ready to crossfire :-). My system specs are:

Crosshair IV Formula Mobo
AMD Phenom II x6 1100T Black Edition
Viper Xtreme DDR3 4GB X2
ATI Radeon HD 5830
WD 1TB HDD 7200rpm
WD 320GB HDD 7200rpm
Hitachi 400GB HD 7200rpm
Asus DVD/RW
Asus VE247 LED Monitor
LG W1952TQ Monitor
Win7 64Bit

May 17, 2012 6:35:14 PM

I Forgot to post my PSU ><. It is an antec 500W
m
0
l
May 20, 2012 6:14:56 PM

I would say your under powered for using all that equipment with that power supply. Its not the power supply though i had the same problem and I was just running a low grade system with a 750W an one of those cards. Im a little under my power requirment rightnow though for my current system

ASUS F1 A75-V EVO
AMD A8 3870k APU x4 3.6 Ghz
Corsair Vengeance 8Gb x4 (32GB 1866mhz)
AMD XFX 6870 Crossfired
Seagate 1TB 7200rpm 6gb/s
Thermaltake 750 watt psu
Westinghouse 46" LED TV 1080p
ASUS VE 245 24" LCD 1080p
Windows 7 Professional
m
0
l
Related resources
May 28, 2012 4:55:27 PM

Thanks for the reply. I did end up buying a 1000W psu, and indeed my problem is still there. So from what you have said, this is an issue with my particular card? If that's the case, I'll be making a different plan than crossfire with another of these same cards..
m
0
l

Best solution

a c 186 U Graphics card
May 28, 2012 5:10:14 PM

Sounds more like you need to turn V-sync on, but can you post a picture of the line/s?
You can force V-sync on through the Catalyst Control Centre: Double click on the CCC icon>Gaming>3d Application settings>Wait for vertical refresh>move the slider all the way to the right (always on), then 'accept'.
Share
June 7, 2012 12:43:48 AM

Vertical sync fixed the issue, thanks!
m
0
l
June 7, 2012 12:43:59 AM

Best answer selected by dbyers24.
m
0
l
!