Sign in with
Sign up | Sign in
Your question
Solved

Can't reach 30 Mbps on Windows 7

Last response: in Windows 7
Share
January 31, 2012 6:22:49 AM

Hi everyone,

I just upgraded my internet connection to 30 Mbps. After running more than 50 speedtests on my computer running windows 7,
I came to the conclusion that there was something wrong because I was never exceeding 17 Mbps on speedtest.net !
I called my ISP and they told me that if they send a tech he will plug a laptop directly to the modem and if he gets 30 Mbps I would have to pay.. while he kept talking I used my Iphone (which is connected to the 30 Mbps connection through my wireless router) and surprisingly got speeds between 21 Mbps and 23 Mbps ! I then realised my modem or router wasnt the problem.

I tried uninstalling AVG antivirus (saw that on some forums), didn't work. I tried to plug my ethernet wire directly in my computer instead of passing through my router, didn't work. I tried the Enable QoS tweak and set it to 0% instead of 20%, didn't work.

I'm using windows 7 ultimate 64 bit - Intel Core 2 Duo 3ghz proc - 8 gb 667mhz DDR3 memory - Onboard 100 mbps network adapter - Geforce GTX 560 (I know it's a waste with the Proc I have but i'll upgrade PC soon)

BTW, I upgraded my internet connection from 8 Mbps to 30 Mbps. the 8 Mbps was maxed out on any speedtests or any popular torrents. After I upgraded i'm getting max 17 Mbps... it seems to cap there for an unknown reason !

I really hope someone can help me out on that.

Thank you very much !

More about : reach mbps windows

a b $ Windows 7
January 31, 2012 8:07:36 AM

Bad cable between router and computer? That or try the other NIC if you have one.
m
0
l
January 31, 2012 8:33:08 AM

Or try a different server on Speedtest.net. I know some are slower than others as far as Ohio servers go, so its possible yours *could* be slow too.

I just ran it and I'm getting crappy speeds too, who's your ISP? Mines Comcast.
m
0
l
Related resources
January 31, 2012 8:47:00 AM

I did try many servers on speedtest.net (4 different ones inside 15km of where I live in Montreal). also tried 2 in the northern US it was barely the exact same results. Going home in an hour i'll try my Dlink USB wireless adapter (suppose to support up to 54 mbps I think) just to see if I can get better results.. if so it might be bad cable or something but it really seems to be a config problem with windows 7 (even though it seems like i'm the only one having this problem)
m
0
l
January 31, 2012 9:38:25 AM

alright so here I am ! tried my USB wireless adapter got samething as on my Iphone around 21 Mbps ! I realised my drivers were out of date so I installed the newest for my intel network adapter ... what happened ? nothing new... stuck at 16-17 Mbps again ! does it matter that the wire from my modem to my router is blue and from my router to my computer its a cheapo gray wire ?
m
0
l
January 31, 2012 10:23:27 AM

Control Panel -- Network and Sharing Center -- Changer Adapter Settings --
Right Click on Network Card then Properties -- Click Configure... -- Advanced Tab --
Performance Options and click Properties -- Interrupt Moderation Rate:
7 choices: Off, Minimal, Low, Medium, High, Extreme, Adaptive..

Was set to Adaptive by default. Tried Off didn't change a thing.. Tried EXTREME and now I get 31.5 Mbps after 10 speedtests !

Thanks for your help !
m
0
l
a b $ Windows 7
January 31, 2012 11:22:47 AM

Interesting, how'd you find this?
m
0
l
January 31, 2012 11:25:38 AM

never saw that option before?
m
0
l
January 31, 2012 11:28:56 AM

4745454b said:
Interesting, how'd you find this?



Tried setting by setting, doing 2-3 tests everytime I changed a setting.. after I changed this one I made like 10 tests and it was obvious.

m
0
l

Best solution

January 31, 2012 11:40:34 AM

You said 100mb NIC? It seems to have been having auto-negotiation issues so setting it manually in the advanced driver settings corrected it. Gigabit NIC's use a better negotiation method. I was going to blame the NIC/driver but as that does seem to be what was the issue, I am glad to have scrolled down and see that you fixed it :) 
Share
a b $ Windows 7
January 31, 2012 11:42:13 AM

I meant how did you know to change this?
m
0
l
January 31, 2012 11:48:28 AM

4745454b said:
I meant how did you know to change this?


Quote:
Control Panel -- Network and Sharing Center -- Changer Adapter Settings --
Right Click on Network Card then Properties -- Click Configure... -- Advanced Tab --
Performance Options and click Properties -- Interrupt Moderation Rate:
7 choices: Off, Minimal, Low, Medium, High, Extreme, Adaptive..



I didn't ! I changed like 30 random things 1 by one, that's what I meant
m
0
l
January 31, 2012 11:48:56 AM

Best answer selected by p0nk1n.
m
0
l
January 31, 2012 11:51:37 AM

Older 100mbps NICs are known to occasionally have auto-negotiation issues, possibly leading to a duplex mismatch which would cause issues. This is a big reason why on older 100mb networking equipment you always make sure to manually configure the speed/duplex on trunk links between switches, when it comes to the desktops you can often go into the advanced driver settings as he did and attempt to manually set the speed/duplex.
m
0
l
a b $ Windows 7
January 31, 2012 11:51:43 AM

I pay for 8 and I get 48, no complaints here.
m
0
l
January 31, 2012 11:57:34 AM

Using a docsis 3 cable modem? The way docsis 3 uses multiple channels makes it nice for some customers on good ISPs since the added channels aren't widely utilized yet due to most still using docsis 2 modems using just a single channel. Definitely 1 area where "speedboost" can be a nice perk :) 
m
0
l
January 31, 2012 12:10:20 PM

mryoink said:
Using a docsis 3 cable modem? The way docsis 3 uses multiple channels makes it nice for some customers on good ISPs since the added channels aren't widely utilized yet due to most still using docsis 2 modems using just a single channel. Definitely 1 area where "speedboost" can be a nice perk :) 


That's right, Docsis 3 ! http://www.arrisi.com/product_catalog/_docs/_specsheet/...
m
0
l
!