Sign in with
Sign up | Sign in
Your question

New graphics card in old motherboard - The ASUS M2N-SLI Deluxe

Last response: in Graphics & Displays
Share
May 18, 2012 4:16:01 PM

I recently installed a new Sapphire Radeon HD 6870 into an ASUS M2N-SLI Deluxe and it did not boot. Blank screen. Did not POST. I tried everything. I RMA'd it and tried another card of the same chipset (XFX Radeon HD 6870) and I got the same results.

Someone mentioned that I should try powering it off, then IMMEDIATELY powering it back on while there's still juice flowing in the hardware. I did that AND IT WORKED!!!! :D  :D  :D 

I'm posting this now so that hopefully it'll be easier if somebody else has this problem.
May 18, 2012 4:18:18 PM

Further:
This seems to happen on various older motherboards and/or power supplies, and I have no idea why. Everything worked fine when I put my old graphics card in, but this new one seems to require this funky little bit of finessing to get it to start up.
m
0
l
May 18, 2012 4:44:00 PM

I had a tv plugged into an outlet controlled by a wall switch. Turned it off one day by accident and turned it immediatly back on.

Fried the TV.

I would be very worried that your "momentary power interuption" will kill your MB and/or HD and/or CPU and/or PSU and/or GPU and/or...

Take a read at other post regarding power interuptions and hardware life expectancy.

In your case it sounds like you need a new higher wattage PSU with enough amps on the 12V rail.

edited for fat finger spelling errors
m
0
l
!