Sign in with
Sign up | Sign in
Your question

GTA 4 Lag on R6850

Last response: in Graphics & Displays
Share
May 19, 2012 2:59:45 PM

Hi guys. When i play GTA 4 i get 25 fps and the game keeps skipping and chopping and changing the graphics settings didn't help either, only i got more fps but the game still keeps skipping and chopping.
Specs:
AMD Radeon HD 6850
AMD Athlon II X3 445 cpu
4gb RAM
all latest drivers for the graphics card installed

More about : gta lag r6850

a b U Graphics card
May 19, 2012 3:51:44 PM

here u can get latest driver of your gpu what psu do you have 6850 requires 500 watt
Related resources
May 19, 2012 3:58:11 PM

monu_08 said:
here u can get latest driver of your gpu what psu do you have 6850 requires 500 watt


Yep. i have a Corsair 500W PSU. i tell ya all games work fine so far except this one. i played dirt 3 on max settings with AA x8 and did a stress test with furmark and its completely stable. the only thing i could come up with is the CPU. oh and the 500W is a recommendation from AMD, its power consumption is 127W which is lower than the slightly weaker GTX 460 that eats 160W
a b U Graphics card
May 19, 2012 4:01:35 PM

may be gta 4 you got its ripped version which have crap graphic and voices
May 19, 2012 4:02:25 PM

If I recall correctly patching the game helped boost performance a bit. The game is terribly ported and is known for performance issues. I do wonder if your CPU is playing a role in this. Next time you play keep a eye on your CPU usage.
May 19, 2012 4:02:36 PM

monu_08 said:
may be gta 4 you got its ripped version which have crap graphic and voices


Dunno. been working fine on my geforce gt 240
a b U Graphics card
May 19, 2012 4:03:48 PM

From what I've heard you need a fast quad core for GTA4.
May 19, 2012 4:06:28 PM

geekapproved said:
From what I've heard you need a fast quad core for GTA4.


here's how its like. i'm getting 42 fps but its constantly chopping when i drive or typing on the in-game phone. when i get out of the car and run it jumps to 60 fps and the game runs smoothly
May 19, 2012 4:12:05 PM

monu_08 said:
pacthing the game will help you to get better fps here link http://megagames.com/games/grand-theft-auto-iv-1


i've been playing gta 4 on patch 1.0.4.0 for almost 2 years now with my gt 240 and now i tried using 1.0.7.0 and still nothing. i keep getting same results
a b U Graphics card
May 19, 2012 4:15:13 PM

it because ati driver have not fully capable for almost games nvidia have better driver support but ati gives performance just wait while ati new driver releases
a c 191 U Graphics card
May 19, 2012 4:23:29 PM

GTAIV is a very very poorly coded game for the PC. They basically just took it from the console and put it onto the PC.
a b U Graphics card
May 19, 2012 4:26:22 PM

I had problems like that playing GTA 4 with my system which is kinda same as yours, just a slower GPU and little faster processor, my FPS where really bad at the beginning but i upgrade to patch 1.0.7 everything changed and i could play smoothly.

if you can, try to unlock your processor's 4th core and overclock it a little, lets say about 3.4ghz and try the game... You note at least 5fps diference or even 10... this game is pretty bad coded and wont use your system properly...
a b U Graphics card
May 19, 2012 4:31:09 PM

dont oc your processor untill u have good cpu cooler becasue stock cooler and oc is not a good option for gaming
a b U Graphics card
May 19, 2012 4:31:42 PM

Has nothing to do with AMD drivers. This isnt 1999. Do a driver sweep and get rid of your old nvidia drivers, and the AMD drivers. Reboot in safe mode to remove them with driver sweep I think its called. And then reinstall 12.4 catalyst drivers.
May 19, 2012 4:37:13 PM

monu_08 said:
dont oc your processor untill u have good cpu cooler becasue stock cooler and oc is not a good option for gaming


coolermaster hyper TX3. no problems there, just need a new motherboard since this one can't overclock or unlock cores
May 19, 2012 4:39:05 PM

vrumor said:
Has nothing to do with AMD drivers. This isnt 1999. Do a driver sweep and get rid of your old nvidia drivers, and the AMD drivers. Reboot in safe mode to remove them with driver sweep I think its called. And then reinstall 12.4 catalyst drivers.


After i replaced my graphics card i reinstalled Windows so that i could get rid of any Nvidia driver existence
a b U Graphics card
May 19, 2012 4:46:04 PM

monu_08 said:
it because ati driver have not fully capable for almost games nvidia have better driver support but ati gives performance just wait while ati new driver releases


^ Crap, very much (besides the punctuation mindfuck).

Deemo13 said:
GTAIV is a very very poorly coded game for the PC. They basically just took it from the console and put it onto the PC.


^ Very true indeed.

vrumor said:
Has nothing to do with AMD drivers. This isnt 1999. Do a driver sweep and get rid of your old nvidia drivers, and the AMD drivers. Reboot in safe mode to remove them with driver sweep I think its called. And then reinstall 12.4 catalyst drivers.


^ This, and last time I tried the guru3d's "Driver sweeper" it was no longer supported. When I went from ATI to Nvidia, doing a full catalyst uninstall+restart+ Nvidia driver install+restart worked perfectly.

Also, check your GPU, RAM and CPU usage when the game is running. I've had my VGA stick to 2D settings once. And make sure you aren't using SSAA (MSAA should be fine).
May 19, 2012 4:48:39 PM

Murissokah said:
^ Crap, very much (besides the punctuation mindfuck).



^ Very true indeed.



^ This, and last time I tried the guru3d's "Driver sweeper" it was no longer supported. When I went from ATI to Nvidia, doing a full catalyst uninstall+restart+ Nvidia driver install+restart worked perfectly.

Also, check your GPU, RAM and CPU usage when the game is running. I've had my VGA stick to 2D settings once. And make sure you aren't using SSAA (MSAA should be fine).


i just did a benchmark test in gta 4. cpu usage was 87% GPU usage was 97% system memory usage was 69%
May 19, 2012 5:08:02 PM

That is quite a bit of both your CPU and GPU. You have to lower the settings a bit.
I know with your current rig your use to pushing pretty decent settings but this game just really is that badly ported.

If you can overclock your CPU and GPU a bit you will also notice a performance boost.
May 19, 2012 5:23:14 PM

NuclearShadow said:
That is quite a bit of both your CPU and GPU. You have to lower the settings a bit.
I know with your current rig your use to pushing pretty decent settings but this game just really is that badly ported.

If you can overclock your CPU and GPU a bit you will also notice a performance boost.


Why GPU? i just upgraded from a GT 240 to a Radeon HD 6850 which is a hell of a huge difference. but a new CPU would be nice
a b U Graphics card
May 19, 2012 5:45:30 PM

Are your settings the same? Did you download CAP (catalyst application profiles)?

Please use GPU-Z and check if the GPU is at the correct frequency when the game is running. Also, verify the 3D settings on your CCC, specifically the antialiasing settings.
!