Sign in with
Sign up | Sign in
Your question

Mandrake Install/Boot Hangs With Win2k/NTFS

Tags:
Last response: in Linux/Free BSD
Share
Anonymous
January 9, 2002 11:15:46 PM

I've found a number of posts dealing with bootup problems AFTER installing Mandrake or other Linux systems into a dual boot with Windows - I'm not getting that far.

I have w2k/ntfs on an existing 20 GB drive. I added a shiney new 40 GB drive, as slave, to install Mandrake 8.1. The two drives are attached through an ultra 66 ATA adapter card. When I try to install Mandrake from the install CD, the system hangs after hitting Enter on the initial window after it displays a screen or so of text output about the devices it has found. The last thing on the screen deals with the drive where w2k/ntfs is installed. When I remove the w2k/ntfs drive and make the new drive master, Mandrake installs and runs just fine. If I add the w2k/ntfs drive back in as slave, Mandrake boot up hangs similar to the install hang.

As a side benefit, the Mandrake install hang often corrupts the w2k/ntfs system (I'm stubborn, I've tried it about 6 - 10 times using different hard drive attach configurations).

Could this be an ntfs incompatability, ATA adapter card problem, or ???

Thanks for any ideas.
January 10, 2002 10:22:42 PM

Hmmm...Interesting...Maybe a controller card problem??

Check to see if it's supported by Mandrake...If it is, I have no clue...

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
Anonymous
January 11, 2002 2:56:41 PM

I haven't actually pulled the ATA adapter card from my box yet to see what it is and check if it's supported, but I went ahead and plugged my drives directly into the motherboard. Amazingly, the install set-up did not hang - I guess the adapter was just another Gateway low-end unit. I went ahead and re-installed Mandrake because I wanted to change some things anyway. When I was done, bootup of Mandrake from LILO also proceeded without hanging.

New Problem: Now shutdown from Mandrake hangs. The last text I see are two lines talking about USB disconnected. I don't see any other posts that talk about this kind of thing. Any idea what this one is?

New Question: Win2k was dead. When I selected it from LILO, the screen just blinked. Okay, I read lots of posts talking about this sort of thing (including your very detailed "Dual Boot RedHat 7.2 and Win2K/ME"), so I wasn't surprised. What did surprise me was the extent of the damage. The win2k install disk would not do anything until it re-formatted the partition. And now I'm talking to the drives without the adapter card, so it takes a really long time. But, when the re-install was done, I could boot both win2k and Mandrake. What surprised me was that LILO was still intact. I admit I don't know as much about boot sectors and such as I'd like, but I expected to see the NT loader and no Mandrake option. Is there a quick explanation or URL that could explain how bootup gets configured, etc?

Many thanks.
Anonymous
January 11, 2002 5:08:16 PM

I have a guess about why LILO was left intact. Perhaps you can confirm or correct this explanation.

Windows install does not write a boot sector; it assumes that fdisk has done it and it's good forever. Mandrake, however, knows Windows doesn't play nice, so it's install writes a boot sector that finds the Windows OSes that exist at the time of install.

It's still not clear to me why win2k gets trashed by the Mandrake install. But at least I'm not the only one...

Now, I just need to fix the Mandrake hang at shutdown.

Edit to post: I thought more about the above and realize that it doesn't make any sense. I'll keep trying to find an explanation.<P ID="edit"><FONT SIZE=-1><EM>Edited by bwanawanabe on 01/11/02 03:31 PM.</EM></FONT></P>
January 12, 2002 6:15:20 PM

Win2k and Mandrake SHOULD get along fine...As long as you use the NT boot manager.

If you selected "NT" from your LILO screen, I think you also need to specify the partition table for LILO, or else it just overwrote some stuff. If the NT hard disk is /dev/hda, include the entry "table=/dev/hda" in the NT stanza in your /etc/lilo.conf file....

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
Anonymous
January 13, 2002 11:31:44 PM

This gets back to something that confused me in your post to "Dual Boot RedHat 7.2 and Win2K/ME". Here it said to choose LILO, rather than cancelling the install of a Linux boot loader, and later it described how to update Windows to include the Redhat system in its boot choices. Should the post have said to cancel out of the step to install Linux boot loader? It sounds like either loader could be used, but different corrective steps need to be taken depending on which you choose (those in the referenced post to use the LILO loader and those described here to use the NT loader). Is this right or am I confused (again)?

Thanks a load for the help.
January 15, 2002 1:02:07 AM

I just know how to configure LILO to NOT overwrite your MBR...The NT loader is happier when it is in the MBR..PLus, you can use it to assign options (such as "/fastdetect") that you can't do with LILO/GRUB.

You need a bootloader, especially for things like "safe mode".

This way, everyone wins...

PS...Remeber to set your bootsector file as "Read-Only"....
I've had trouble with XP hosing this file from time to time.

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
!