Sign in with
Sign up | Sign in
Your question

Display Drivers Spontaneously Stop Responding & Recover

Last response: in Graphics & Displays
Share
May 20, 2012 7:03:18 AM

Alright I know you guys have heard this story before, but I've spent the past couple weeks, trying everything every article has suggested, and still the problem persists. So here are the symptoms:

At random times, whatever program I'm in (most commonly a browser, though not limited to any one) will freeze. The cursor will still move for a couple seconds, but eventually freeze as well--after 3 to 5 seconds, the whole screen goes black, and everything is back to normal. That's when the message "Display drivers have stopped responding and have recovered" comes up.

What's curious is that these messages will never appear while I'm gaming (League of Legends, StarCraft, and the like). In addition, I have had Windows freeze as it is loading (obviously without the recovery message), and most commonly as I am logging in. In fact, I have had incidents in which My desktop is unusable for the first 30 seconds after logging in, because the display keeps freezing, recovering, and freezing as it is recovering again, without any input or action taken. What gets me is the irregularity; I go some days only experiencing it a handful of times, and other days (like today, which has spurred me to start this), a minimum of 30 times. Not very conducive to work, as you might imagine.

So before anyone asks, yes I've read the articles published by both Microsoft and AMD on this issue, and yes I've scoured the forums for every resolved incident as well. Let's see if I can remember everything I've tried:
- Installed all the latest updates for Windows
- Installed the latest Catalyst drivers
- Reinstalled multiple Catalyst versions, using DriverSweeper inbetween tests
- Overclocking GPU
- Underclocking GPU
- Increased TDR registry value
- Replaced GPU altogether (went from a 7770 to a 6870)
- Clean-installed Windows 7 (twice now)
- Changed power settings (sleep mode, etc)
- Booted with one stick of RAM (twice with different sticks)
- Changed RAM slots
- Changed PCIe slots
- Replaced PSU (incidental need, both were 650W)

Aaand, my system specs:
Intel i7 2600k
Asus Maximus IV Gene-Z
OCZ 90GB SSD
8GB Ripjaw RAM
650W Rosewill PSU

About the only things I haven't tried are MemTesting the RAM (I have no CD burner and see no point when I've tried multiple sticks), trying an nVidia GPU, and updating the BIOS, but that's only because my mobo refuses any and all attempts to update, flash, and overwrite the BIOS. And yes, I've tried everything under the sun to get that going to. So I'm curious if, because of that, this might be a symptom of the Motherboard? I've gone through so much hassle it could be anything at this point. So in short: Does anyone have any other ideas of what I could try, before I RMA the Mobo too?
May 20, 2012 11:39:25 AM

Hi

As you said, it could be anything, so my stab in the dark is that your GPU isn't stable at its idle power state (as you don't experience the issue in games), so I would get 2 copies of the graphics cards BIOS (from GPU-Z), edit one of them so that the idle power state voltage is slightly higher (Use RBE to edit BIOS) then save the BIOS, put the original and new BIOS on a memory stick and flash the card in DOS.
I'm not saying that my idea will fix your issue, its only what I would try, I'd also run Prime95 blend mode for 12 hours to make sure your RAM and CPU are stable.

Good luck man
m
0
l
May 20, 2012 11:55:37 AM

Apparently this issue affects both Nvidia 5xx series AND AMD too?

I too used to get the same error regardless of browser, It was mostly(I haven't seen one in months *knocks on simulated wood*)fixed by disabling GPU acceleration in Flash, Firefox and Chrome. I have also updated drivers in the time since I had them as well.

Nvidia was working hard trying to nail down the issue and fix it. I'm not brave enough to re-enable GPU acceleration though to see if they did fix it.

And you can use a flash drive for Memtest, http://www.memtest.org/download/4.20/memtest86+-4.20.us... so you can test your ram without a CD/DVD burner.
m
0
l
Related resources
May 20, 2012 2:46:18 PM

Okay here, try this. To stop throttling in AMD vision center blah blah, go to the presets tab, and click add preset. Name it whatever it doesnt matter. Then go to C:\Users\******\AppData\Local\ATI\ACE\Profiles

Edit this file in notepad. You should see where it says Property name="Want_0", Property name="Want_1", Property name="Want_2", a few times. These are states of clock speeds. every time you see them grouped like that, change all the values for them to the highest of the three. for example:

Change
Want_0 = 20000
Want_1 = 50000
Want_2 = 77500

to

Want_0 = 77500
Want_1 = 77500
Want_2 = 77500

Do that for all the parts of the file that are set up like that and save the file. Then, in your amd drivers, click on the preset. You'll have to click on it every time you start your pc most likely but oh well.

This isn't a surefire fix or anything but it looks like maybe your idle clocks are making the GPU unstable, and for some reason some GPU's (mine included) don't like to be underclocked and undervolted. Make sure you change EVERY set of 3 Want_# things to the highest value. If you don't and there is a voltage tier, you'll be setting the card to max clocks with minimum voltage.
m
0
l
May 22, 2012 8:45:05 PM

Firstoff, thanks for the reply guys.

So turning off the graphics acceleration in all browsers definitely helps--I've no idea why I hadn't thought to try this earlier, but I'm grateful. The problem didn't stop completely, but at least I can tab in and out with glee.

I tried abyssalx's suggestion of adding a preset and editing the profile, but it has not worked entirely. It definitely decreased the number of times I get the error (outside of the browser), but it still persists, even after startup (which is becoming a huge pain, as no I get no visuals until the Windows login screen).

I have not yet tried to flash the GPU BIOS, but I will try that this afternoon. I just wanted to bring up another potential symptom that I did not notice until now: apparently I can't dual-screen. I didn't try before today, so it may have always been this way, but while my computer can definitely recognize other monitors, any and all attempts to extend the desktop result in "Error: The settings could not be saved."

Is it possible I just got a bunk graphics card? I don't even know how to start troubleshooting the display issues.
m
0
l
!