Sign in with
Sign up | Sign in
Your question
Closed

Windows cannot be installed to this disk.

Tags:
Last response: in Windows 7
Share
January 31, 2012 4:34:00 PM

Hey guys,

Just got a Corsair Force 3 120GB SSD and want to do a clean install of Windows 7 64bit on to it.

However, when I get to the 'Where do you want to install windows?' screen, I get the error message:

'Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu.'

Any suggestions?



Additional information:

Specs are in my signature
I do no have another HDD plugged in (it is to the PSU, but not via SATA to the mobo)

More about : windows installed disk

January 31, 2012 4:44:34 PM

Well did you go into the Bios and set the Boot Priority?
January 31, 2012 4:44:51 PM

Make sure you set your BIOS to AHCI instead of SATA.
Related resources
January 31, 2012 5:32:19 PM

Im in the bios now, (on these forums using my laptop) under the Boot tab and I have these options:

Priorities:
Boot Option 1 - SATA: HL-DT-STDVD+-RW GSA-H31L
Boot Option 2 - UEFI: HL-DT-STDVD+-RW GSA-H31L

(I can only choose SATA or UEFI for each option)
January 31, 2012 5:37:21 PM

Edit: Now Im in the advanced tab I can see this:

Advanced/Storage Priorites:

Marvell SATA3 Operation Mode: IDE Mode
Bootable: No

SATA Mode: IDE Mode
Controller 0: Compatible
Controller1: Enabled
Hard Disk S.M.A.R.T: Disabled


SATA3_0: Not Detected
SATA3_1: Not Detected
SATA2_2: HL-DT-STDVD+-RW GSA-H3 ATAP1
SATA2_3: Not Detected
SATA2_4: Not Detected
SATA2_5: Not Detected
a b $ Windows 7
January 31, 2012 5:40:08 PM

Shutdown your PC, make sure the connectors are properly seated (including power), then restart. In the BIOS, you want to be in AHCI rather than IDE mode (although the drive should still show up; you won't have TRIM nor best performance in IDE mode). If the drive still doesn't show up in the BIOS, you got a DOA.
January 31, 2012 5:43:03 PM

The drive can be found, I tested that by reconnecting my bootable HDD and using my SSD as a data drive, it found it, partitioned it and I copied files onto it which I used. So the SSD is fine
a b $ Windows 7
January 31, 2012 5:51:05 PM

In the above screens, it is not appearing in your BIOS. Does it look like a USB device to Windows? Is it formatted as NTFS?

Best solution

a b $ Windows 7
January 31, 2012 5:57:45 PM
Share

You are connecting to the INTEL sata III port correct, NOT the marvel controller.
You need to set Intel controller to AHCI mode.
Disable marvel sata III controller unless you are using - Marvel controller OK for HDD (But should also be set to AHCI mode, not IDE.) But really very little advantage of connecting a Sata III HDD to SATA III port anyway.

I have the Non gen3 Asrock extrem4 MB and had no problems setting up a aggility III with windows 7. Just last week removed the agillity III and installed my new Samsung 830, again running smoothly. At work so can not access my Bios.
My current set up
Intel sata III port 0 - 128 gig Samsung 830
Intel sata III port 1 - 120 gig Agility III
Intel sata II port 4 - 1 TB samsung F3 HDD
Intel sata II port 5 - LG Blu-ray Writer.

NOTE: Your Intel port should be set to AHCI, NOT IDE and SMART should be enabled.
When you get to installing windows - DO A Custom instal and DELETE all partitions you have created!!
January 31, 2012 6:06:11 PM

Right guys, I figured out what the problem was regarding the bios not showing the SSD - I had it plugged into a marvel SATA3 socket.

Ive now reconnected it to the recommended intel one, and it now shows up so the screen looks like this:

Advanced/Storage Priorites:

Marvell SATA3 Operation Mode: IDE Mode
Bootable: No

SATA Mode: IDE Mode
Controller 0: Compatible
Controller1: Enabled
Hard Disk S.M.A.R.T: Disabled


SATA3_0: Corsair Force 3 SSD
SATA3_1: Not Detected
SATA2_2: HL-DT-STDVD+-RW GSA-H3 ATAP1
SATA2_3: Not Detected
SATA2_4: Not Detected
SATA2_5: Not Detected


so, what what options here do I need to change? :) 
a b $ Windows 7
January 31, 2012 6:08:13 PM

As I stated:
Controller = AHCI, not IDE and then enable SMART.

Also, I'd stick your DVD drive on one of the last two Intel sata II ports.
a b $ Windows 7
January 31, 2012 7:01:20 PM

Ah, now you're cooking with gas.
a b $ Windows 7
January 31, 2012 7:25:37 PM

Sata Mode : IDE mode should be ACHI mode. Not IDE.
February 6, 2012 11:00:30 PM

Best answer selected by Gallarian.
a c 371 $ Windows 7
February 6, 2012 11:16:15 PM

This topic has been closed by Area51reopened
!