Sign in with
Sign up | Sign in
Your question

[Graphics Cards] GTX 560 Ti

Last response: in Graphics & Displays
Share
May 21, 2012 8:35:27 AM

Hi, so currently I owend a gateway 4200 and the specs are here http://www.newegg.com/Product/Product.aspx?Item=N82E168... and I recently upgraded my power supply, video card and hard drive to a ssd since my old one failed.
The video card I upgraded to was the GTX 560 Ti and the power supply is the one in this link http://www.memoryexpress.com/Products/MX35073.

So I get home and install everything and I also installed windows 7 and got every running smoothly and the computer started so I figured nothing was wrong. I played some games of SC2 and diablo 3 only to find out that I have some major FPS drops during times of high load and from what I know this video card should not be dropping down to 10 FPS or under when I was recently sitting at 70-80+. I was wondering if this could be a power supply issue? I was thinking of dropping back to where I got mine from upgrading to either
http://www.memoryexpress.com/Products/MX35075
or
http://www.memoryexpress.com/Products/MX36481.
Reason why I'm wondering if it really is the power supply is because I've been searching over the web and seem to have a lot of mixed answers as if the PSU can affect GPU performance.

More about : graphics cards gtx 560

May 21, 2012 8:46:39 AM

also forgot to add that drivers are all updated and I did a clean install of windows
m
0
l
May 21, 2012 12:53:46 PM

Just another update to add to my problem.
It doesn't really matter what setting I run SC2 on (Low or Ultra) but in team games once there is a lot of units my fps will drop down to 30 and as more units are created it can go down to as low as 10-15 even on low settings.
m
0
l
!