Sign in with
Sign up | Sign in
Your question

Can't Seem to Detect Brand New Sapphire 7850

Last response: in Graphics & Displays
Share
May 22, 2012 12:20:39 AM

I finished my first new system build as of last night. I hooked my monitor up to my motherboard via hdmi initially to load windows 7. Everything worked fine up to this point, windows 7 is up and running and I can access internet and all that jazz. My problem is that the computer doesn't seem to be able to detect my sapphire 7850. I looked up possible fixes and have tried re-seating the card, disabling and uninstalling the on board graphics, etc. When I downloaded the drivers for the card, I see that it has downloaded the catalyst application. In the instructions, it states that all I have to do is disable any currently operating VGA graphics, which I did, and then download the drivers and restart and I my computer should be able to detect new hardware. I haven't seen any new hardware alerts come up. Tomorrow is the end of my 15 day period in which I can RMA the card with direct canada. Any help would be greatly appreciated. I really like this card and I really don't want to have to pay $36 in restocking fees just because I'm doing something wrong. Thanks in advance!
July 20, 2012 1:12:17 AM

I have the exact same problem. Commenting just to follow the thread.
m
0
l
a c 181 U Graphics card
July 20, 2012 4:11:55 AM

Is the cable to the monitor plug into the card or the MOBO? You have the 6pin connectors going to the card? In the bios does it show you the card and in device manager under display adaptors as well?

And in the bios you disabled the integrated GPU? And when you did disabled it that you had the 7850 out of the case?. Before you send back the card do you know anybody you can try your card in someone's eles's rig?

When you boot up does the cards fan start and do you get any beeps? I will try to get back here in the morning to see what you have to say and good luck.

m
0
l
Related resources
!