Sign in with
Sign up | Sign in
Your question

Can't change My Documents folder location

Last response: in Windows XP
Share
Anonymous
March 31, 2005 5:26:31 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

Hello--

I've been trying to change the "My Documents" location, by following the
standard instructions: open the Start Menu, right-click and choose
"Properties" for "My Documents" and then type in the name of the new folder.

However, it won't accept any typed input; I can't paste anything in
there, either (even though it is a standard text-edit type control), and
there is nothing else on the property page. There seems to be some kind
of setting, somewhere, blocking my changing this. And yet this isn't the
original location of the 'My Documents' folder--I was able to change it
once to where it is now.

I'm running XP Professional, SP2. Does anyone have any thoughts why this
might not allow me to change it?

Thanks for any help in advance--
Anonymous
March 31, 2005 5:26:32 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

Edit HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell
Folders, value Personal.
Anonymous
March 31, 2005 6:01:05 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

Scott, check at Kelly's http://www.kellys-korner-xp.com/xp_abc.htm
Select M and scroll to MyDocuments Move
"Scott Foglesong" <scottlf@mindspring.com> wrote in message
news:blI2e.2554$x4.2284@newsread1.news.pas.earthlink.net...
> Hello--
>
> I've been trying to change the "My Documents" location, by following the
> standard instructions: open the Start Menu, right-click and choose
> "Properties" for "My Documents" and then type in the name of the new
> folder.
>
> However, it won't accept any typed input; I can't paste anything in there,
> either (even though it is a standard text-edit type control), and there is
> nothing else on the property page. There seems to be some kind of setting,
> somewhere, blocking my changing this. And yet this isn't the original
> location of the 'My Documents' folder--I was able to change it once to
> where it is now.
>
> I'm running XP Professional, SP2. Does anyone have any thoughts why this
> might not allow me to change it?
>
> Thanks for any help in advance--
Related resources
Anonymous
March 31, 2005 6:10:42 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

Rich Barry wrote:
> Scott, check at Kelly's http://www.kellys-korner-xp.com/xp_abc.htm
> Select M and scroll to MyDocuments Move
> "Scott Foglesong" <scottlf@mindspring.com> wrote in message
> news:blI2e.2554$x4.2284@newsread1.news.pas.earthlink.net...
>
>>Hello--
>>
>>I've been trying to change the "My Documents" location, by following the
>>standard instructions: open the Start Menu, right-click and choose
>>"Properties" for "My Documents" and then type in the name of the new
>>folder.
>>
>>However, it won't accept any typed input; I can't paste anything in there,
>>either (even though it is a standard text-edit type control), and there is
>>nothing else on the property page. There seems to be some kind of setting,
>>somewhere, blocking my changing this. And yet this isn't the original
>>location of the 'My Documents' folder--I was able to change it once to
>>where it is now.
>>
>>I'm running XP Professional, SP2. Does anyone have any thoughts why this
>>might not allow me to change it?

Thanks very much for the tip. I tried the ideas on the Kelly's Korner
site, but even TweakUI wouldn't work given that 'My Documents' was the
one 'Special Folders' that wasn't listed there.

I'm still at a loss here as to what's causing this weird problem. It's
as though XP has decided that I will have the 'My Documents' folder at
this location, and no other location--even though I moved it before from
the default to the location at which it currently resides.

Cheers...
Anonymous
March 31, 2005 8:25:45 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

David Candy wrote:
> Network admins can prevent users moving MyDocs.
> DisablePersonalDirChange
> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
>
> Data type Range Default value
> REG_DWORD 0 | 1 0
>
> Description
> Prevents users from moving the My Documents folder.
>
> This entry stores the setting of the Prohibit user from changing My Documents path Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.
>
> Value Meaning
> 0 (or not in registry) The policy is disabled or not configured. Users can move the My Documents folder.
> 1 The policy is enabled. Users cannot move the My Documents folder.
>
> By default, a user can move the My Documents folder by typing a new path in the Target box of the My Documents Properties dialog box. If the value of this entry is 1, then when users type a new path in the Target box, a message appears explaining that a policy prevents the action.
>
> Change method
> To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit user from changing My Documents path policy (User Configuration\AdministrativeTemplates\Desktop).
>
> Tip
>
> For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.
>
> For general information about Group Policy, see Group Policy in Windows 2000 Help.
>
> To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.
>
>
Thanks for this detailed and careful solution. Alas: it's already set to
0 on my computer, so that doesn't seem to be the issue. Or am I missing
something else--?

Thanks,
Scott
Anonymous
March 31, 2005 4:30:16 PM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

PS 0 still sets the policy - the valie must be deleted.

--
----------------------------------------------------------

"Scott Foglesong" <scottlf@mindspring.com> wrote in message news:C_I2e.2567$x4.460@newsread1.news.pas.earthlink.net...
> Rich Barry wrote:
>> Scott, check at Kelly's http://www.kellys-korner-xp.com/xp_abc.htm
>> Select M and scroll to MyDocuments Move
>> "Scott Foglesong" <scottlf@mindspring.com> wrote in message
>> news:blI2e.2554$x4.2284@newsread1.news.pas.earthlink.net...
>>
>>>Hello--
>>>
>>>I've been trying to change the "My Documents" location, by following the
>>>standard instructions: open the Start Menu, right-click and choose
>>>"Properties" for "My Documents" and then type in the name of the new
>>>folder.
>>>
>>>However, it won't accept any typed input; I can't paste anything in there,
>>>either (even though it is a standard text-edit type control), and there is
>>>nothing else on the property page. There seems to be some kind of setting,
>>>somewhere, blocking my changing this. And yet this isn't the original
>>>location of the 'My Documents' folder--I was able to change it once to
>>>where it is now.
>>>
>>>I'm running XP Professional, SP2. Does anyone have any thoughts why this
>>>might not allow me to change it?
>
> Thanks very much for the tip. I tried the ideas on the Kelly's Korner
> site, but even TweakUI wouldn't work given that 'My Documents' was the
> one 'Special Folders' that wasn't listed there.
>
> I'm still at a loss here as to what's causing this weird problem. It's
> as though XP has decided that I will have the 'My Documents' folder at
> this location, and no other location--even though I moved it before from
> the default to the location at which it currently resides.
>
> Cheers...
Anonymous
March 31, 2005 4:30:17 PM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

David Candy wrote:
> PS 0 still sets the policy - the valie must be deleted.
>
Whoops...I answered your previous message before deleting the value
altogether, assuming that 0 meant the policy was disabled. Thank you so
much: that worked!!

Big sigh of relief....

Cheers,
Scott
Anonymous
March 31, 2005 6:27:58 PM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

The post I made one second after this one.

--
----------------------------------------------------------

"Scott Foglesong" <scottlf@mindspring.com> wrote in message news:D ZK2e.8076$H06.7033@newsread3.news.pas.earthlink.net...
> David Candy wrote:
>> Network admins can prevent users moving MyDocs.
>> DisablePersonalDirChange
>> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
>>
>> Data type Range Default value
>> REG_DWORD 0 | 1 0
>>
>> Description
>> Prevents users from moving the My Documents folder.
>>
>> This entry stores the setting of the Prohibit user from changing My Documents path Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.
>>
>> Value Meaning
>> 0 (or not in registry) The policy is disabled or not configured. Users can move the My Documents folder.
>> 1 The policy is enabled. Users cannot move the My Documents folder.
>>
>> By default, a user can move the My Documents folder by typing a new path in the Target box of the My Documents Properties dialog box. If the value of this entry is 1, then when users type a new path in the Target box, a message appears explaining that a policy prevents the action.
>>
>> Change method
>> To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit user from changing My Documents path policy (User Configuration\AdministrativeTemplates\Desktop).
>>
>> Tip
>>
>> For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.
>>
>> For general information about Group Policy, see Group Policy in Windows 2000 Help.
>>
>> To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.
>>
>>
> Thanks for this detailed and careful solution. Alas: it's already set to
> 0 on my computer, so that doesn't seem to be the issue. Or am I missing
> something else--?
>
> Thanks,
> Scott
July 18, 2011 7:17:41 PM

THIS WORKED !!!!

Quote:
Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windows.perform_maintain (More info?)

David Candy wrote:
> PS 0 still sets the policy - the valie must be deleted.
>
Whoops...I answered your previous message before deleting the value
altogether, assuming that 0 meant the policy was disabled. Thank you so
much: that worked!!

Big sigh of relief....

Cheers,
Scott

!