Sign in with
Sign up | Sign in
Your question

LCD problems with V3 Razr

Last response: in Network Providers
Share
Anonymous
August 16, 2005 12:02:49 PM

Archived from groups: alt.cellular.cingular (More info?)

I just got my Razr yesterday and charged it and activated, and when I
made a call and closed the lid all was fine. The next time I opened the
lid, the screen image was completely reversed, and the top portion of
the screen was at the bottom. Later I went to open the lid and the
screen was completely white, no text, no icons, nothing. Power off and
power on fixed it. What a POS.

More about : lcd problems razr

Anonymous
August 17, 2005 10:57:17 PM

Archived from groups: alt.cellular.cingular (More info?)

[POSTED TO alt.cellular.cingular - REPLY ON USENET PLEASE]

In <1124204569.897546.295910@f14g2000cwb.googlegroups.com> on 16 Aug 2005
08:02:49 -0700, pcerio@gmail.com wrote:

>I just got my Razr yesterday and charged it and activated, and when I
>made a call and closed the lid all was fine. The next time I opened the
>lid, the screen image was completely reversed, and the top portion of
>the screen was at the bottom. Later I went to open the lid and the
>screen was completely white, no text, no icons, nothing. Power off and
>power on fixed it. What a POS.

Sounds like a defect. Can happen with any product. Get it replaced under
warranty. No biggie.

--
Best regards, HELP FOR CINGULAR GSM & SONY ERICSSON PHONES:
John Navas <http://navasgrp.home.att.net/#Cingular&gt;
Anonymous
August 20, 2005 12:57:01 AM

Archived from groups: alt.cellular.cingular (More info?)

Funny enough I had that problem, and was nigh onto getting it replaced. The
it stopped and hasn't come back. I, just like you, I had the problem within
the first 2 days of having the phone, but once it went away, I haven't seen
it again in the past 2 weeks. Might be some kinda of weird little burn in
phase, I dunno


<pcerio@gmail.com> wrote in message
news:1124204569.897546.295910@f14g2000cwb.googlegroups.com...
> I just got my Razr yesterday and charged it and activated, and when I
> made a call and closed the lid all was fine. The next time I opened the
> lid, the screen image was completely reversed, and the top portion of
> the screen was at the bottom. Later I went to open the lid and the
> screen was completely white, no text, no icons, nothing. Power off and
> power on fixed it. What a POS.
>
!