0xc000007b Error

So I currently found out about Waterfox (64bit version of Firefox) and I installed it, since I have windows 7 64bit. After installing it, an application error came up saying "The application was unable to start correctly (0xc000007b). Click OK to close the application." I already installed all the required softwares to run Waterfox (java 64bit, silverlight 5, Visual C++ 2010 Redistributable Package (x64), and adobe flash 11 64bit). Still no luck. I even tried uninstalling Mozilla Firefox first and reinstalling Waterfox since they both use the same profile to load the browser along with running "firefox.exe" and I thought those things could be conflicting for the application to run but still no luck. Does anyone know what kind of error this is and how I can solve this problem? Thanks in advance.
5 answers Last reply
More about 0xc000007b error
  1. Quote:
    # for hex 0xc000007b / decimal -1073741701 :
    STATUS_INVALID_IMAGE_FORMAT ntstatus.h
    # {Bad Image}
    # The application or DLL %hs is not a valid Windows image.
    # Please check this against your installation diskette.
    # 1 matches found for "c000007b"


    Very interesting, as the OS thinks the application is not a valid windows program. So either the OS install is corrupted, or you have a potential HW problem [possibly RAM].
  2. the hw is still brand new and i haven't made any modifications to any of the hw. as for the os, i already tried installing it on another machine and had the same error when i tried to run waterfox.
  3. Just to clarify, this IS a legal version of Windows, right?

    Might just be the application then...
  4. gamerk316 said:
    Just to clarify, this IS a legal version of Windows, right?

    Might just be the application then...



    im getting this error too, but for rocketdock. not trying to start a topic just wanted to say my waterfox works perfectly well on win7 64. did have some issues with it at the start but a quick reinstall of waterfox fixed that
  5. good day all. ok i have win 7 ultimate not 64bit and i have the same error but with vodacom vmb application to run my modem.
    i got it yesterday and installed it and wam i got that error no logs nothing. no other programes does this that i know of yet please help me
Ask a new question

Read More

Firefox Windows 7