Sign in with
Sign up | Sign in
Your question
Solved

New Z77 Motherboard and CPU

Last response: in Systems
Share
July 16, 2012 9:31:07 PM

I got this combination at WoW forums (http://us.battle.net/wow/en/forum/topic/4850585139#7):

CPU - Intel i3-2120

Mobo - BIOSTAR B75MU3+

RAM - Gaming Mushkin Enhanced Blackline 8GB (2 x 4GB)

GPU - XFX Double D HD-687A-ZDFC Radeon HD 6870

PSU - PC Power and Cooling Silencer MK III 500W

HDD - Western Digital Caviar Blue WD5000AAKX 500GB 7200 RPM 16MB Cache SATA 6.0Gb/s 3.5"

I been having problem with BIOSTAR B75MU3+'s on-board VGA driver, no matter which version I installed. If I install latest version, I will always get black screen after reboot. If I install the CD version in the box, it will stock at welcome page after reboot.

Three weeks ago, I finally got it to work by skipping on-board VGA driver then plug in and install HD6870 driver.

Two days ago, PC keeps rebooting by it self with HD6870 unplug.....unlikely to be the PSU.

Two of the local specialist suggested that I exchange BIOSTAR to ASUS or GIGABYTE.

Since I am gonna get an exchange, I might as well get a Z77 motherboard and i5 CPU!!!

I want a cheap z77 ASUS or GIGABYTE mobo that is got the capacity to run SLi / CrossFireX.

A i5 CPU that will not be overclock, would i5-2300 or i5-3450 CPU works?

Can anyone get me some guidance ASAP?

Still got four days till exchange deadline!!

More about : z77 motherboard cpu

a c 179 à CPUs
July 16, 2012 10:15:03 PM

on your old hardware did you flash the bios to the new 508 bios for the new cpu code.
did you install the new intel chipset driver from intel web page then reboot and then install the intel video driver for the cpu/gpu??

http://downloadcenter.intel.com/SearchResult.aspx?lang=...

also with the new x68 and z chipset that have the mvp chipset. there a first video in the bios.where you can set the bios to boot from onboard or the gpu. also the mvp software is buggie as hell. i would uninstall it if you have it. if the igpu and gpu are working fine there should only be a slight blink on the main monitor.
Related resources
July 16, 2012 10:31:17 PM

smorizio said:
on your old hardware did you flash the bios to the new 508 bios for the new cpu code.
did you install the new intel chipset driver from intel web page then reboot and then install the intel video driver for the cpu/gpu??

http://downloadcenter.intel.com/SearchResult.aspx?lang=...



It's a three weeks old build. It's all new.

I only install the chip set and on-board VGA driver BIOSTAR provided.

Best solution

a b à CPUs
July 16, 2012 10:54:07 PM
Share

detown said:
Isn't i53570K a bit too much? I won't overlock, and I already have HD 6870


If you're not going to overclock then you don't need Z77. Try this:

- Motherboard: http://www.newegg.com/Product/Product.aspx?Item=N82E168...
- CPU: http://www.newegg.com/Product/Product.aspx?Item=N82E168...
a b à CPUs
July 16, 2012 11:35:28 PM

detown said:
would this GIGABYTE board give me the capacity to run SLi / CrossFireX?


It has 1 PCI 3.0 x16 lane and one PCI 2.0 x 16 lane, so yeah it should.
July 19, 2012 5:03:32 AM

Best answer selected by detown.
!