Sign in with
Sign up | Sign in
Your question
Closed

Crossfire, which card to plug into

Last response: in Graphics & Displays
Share
May 24, 2012 3:55:41 AM

Hello,

I recently upgraded my system from having one 6950 2GB to having two 6950 2GB's in Crossfire. I assumed it didn't really matter which card I plugged my HDMI cable into, so I just stuck it into one (the bottom, second slot one) and it seemed to work. But I realized it wasn't showing the splash screen and the options to boot into BIOS that I normally see when I start up my computer; my monitor just wouldn't show anything until it got to the Windows login screen. And weirdly, when I plugged the HDMI cable from my monitor into my other video card, I was able to see the usual splash screen and then boot into BIOS. But when I got out of the BIOS and started my computer up normally, I had to switch back to the other, original card for anything to be displayed.
So--in short, one card will exclusively display the BIOS and startup screen when plugged into; the other will only display Windows once I'm booted up.
Why is this happening, and how can I make it so one card is able to display everything?

Thanks for the help, everyone.

-Charlie

More about : crossfire card plug

a b U Graphics card
May 24, 2012 4:37:50 AM

First of all, have you to make sure your crossfire is enabled:
1. Have you put the crossfire bridge between the two 6950?
2. Have you enabled crossfire in Catalyst?
Score
0
May 24, 2012 12:27:40 PM

randomkid said:
First of all, have you to make sure your crossfire is enabled:
1. Have you put the crossfire bridge between the two 6950?
2. Have you enabled crossfire in Catalyst?

I don't think you understand--Crossfire is enabled, I get greatly increased performance in games and I've taken both of those steps. My issue is different--read the post please.
Score
0
Related resources
May 24, 2012 12:53:54 PM

you need to check your bios settings to ensure you have one pci slot designated as the primary - typically you'll have two options - check your mobo manual for further instructions.
Score
0
a b U Graphics card
May 24, 2012 12:56:59 PM

cskoler said:
I don't think you understand--Crossfire is enabled, I get greatly increased performance in games and I've taken both of those steps. My issue is different--read the post please.

I read it. If you turn sour because I made a suggestion which might be obvious to you. But understand that these is not the case to responders in the thread so we ask. You could have answered with simple "yes, I am sure" & we can go on & continue to help. But with your attitude, I'd rather not stay in this thread. I am out of here.
Score
0
May 24, 2012 1:03:58 PM

randomkid said:
I read it. If you turn sour because I made a suggestion which you could have answered with simple "yes, I am sure", then I am out of here.

I didn't mean to come across as "sour." I just get annoyed when people don't really read an entire post before replying. But I guess it did make sense for you to ask that question, so never mind.
Score
0
a b U Graphics card
May 24, 2012 1:25:51 PM

Your issue is likely windows related. It seems that your bios believes that the PCIe 1 (top) slot is primary where as windows beleive thats PCIe 2 (bottom) slot is primary. It may be possible to kick-start windows into thinking PCIe 1 is primary by un-coupling the two cards, rebooting, logging into windows, doing a complete shut down, re-couping the cards, rebooting, and relogging in. You have to have the HDMI cable plugged into PCIe 1 card after you un-couple the cards. You may have to remove the second card for this to properly work. I had a similar issue but resolved it by removing the second card temporarly. If this doesn't work, a reinstall of windows will.
Score
0

Best solution

a c 216 U Graphics card
May 24, 2012 2:23:38 PM

In the BIOS on my system, I have an option to select "Init PCIe slot". This will change which card will be the primary card. It is possible that your bios will only be seen from the top slot, then use Init PCIe slot once you are past the splash screen.

Another possibility is that you need to disable crossfire, shut down, plug your cables into the top slot, start up and install your AMD drivers. Then re-enable crossfire.

I'm leaning towards the 1st one to be the issue.
Share
a b U Graphics card
May 24, 2012 3:07:49 PM

As already stated, you need to specify which card is the Primary in the BIOS and then you also need to make sure that the same card is the primary card the crossfire setup. Only the primary card in a crossfire setup will output video. The second card will render frames but outputs through the first card. Boot up the computer with ONE card installed and make sure it is in the primary pci-e slot. Now shut down and install the second card with the crossfire cable. Reboot and enable crossfire in CCC. I thought CCC would have detected which card had the monitor plugged into it and reset itself accordingly but it looks like it did not in your case. Following the steps I outlined should reset everything for you. Good luck.
Score
0
May 24, 2012 3:39:13 PM

Best answer selected by cskoler.
Score
0
a c 271 U Graphics card
May 24, 2012 8:33:18 PM

This topic has been closed by Mousemonkey
Score
0
!