Sign in with
Sign up | Sign in
Your question

Here's how to remove the x'd out LAN icon from the system ..

Last response: in Windows XP
Share
Anonymous
April 1, 2005 10:07:03 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Here is the fix for the x'd out LAN icon that just won't go away.

===============================================

Fire up reshack and open c:\windows\system32\netshell.dll

+Icon Group
|
|
|
195
|
*1033

right click on that "1033" and click "Delete Resource [Icon Group : 195 :
1033]

save it as netshell.dll.mod in windows\system32

Boot into Safe Mode in command prompt. Type:

cd\
cd windows\system32
del netshell.dll
ren netshell.dll.mod netshell.dll

shutdown -r -f -t 01

=================================================

And voila! The dreaded x'd out LAN icon is gone for good and the system
tray works perfectly.

More about : remove lan icon system

April 2, 2005 9:47:55 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi,

1. Why is the lan icon x'd out? What are the circumstances?
2. As for the netshell.dll you probably didn't need Reshack to do it.
3. Thanks for the info.

--

All the Best,
Kelly (MS-MVP)

Troubleshooting Windows XP
http://www.kellys-korner-xp.com


"saynotogmos" <saynotogmos@discussions.microsoft.com> wrote in message
news:0CBAAADE-4F16-43CE-BF98-620F06A2ABCE@microsoft.com...
> Here is the fix for the x'd out LAN icon that just won't go away.
>
> ===============================================
>
> Fire up reshack and open c:\windows\system32\netshell.dll
>
> +Icon Group
> |
> |
> |
> 195
> |
> *1033
>
> right click on that "1033" and click "Delete Resource [Icon Group : 195 :
> 1033]
>
> save it as netshell.dll.mod in windows\system32
>
> Boot into Safe Mode in command prompt. Type:
>
> cd\
> cd windows\system32
> del netshell.dll
> ren netshell.dll.mod netshell.dll
>
> shutdown -r -f -t 01
>
> =================================================
>
> And voila! The dreaded x'd out LAN icon is gone for good and the system
> tray works perfectly.
>
>
>
Anonymous
April 2, 2005 10:51:08 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Thanks, Kelly.

1. The LAN icon was x'd out because I have a 1 gig ethernet card that isn't
connected because I'm not using it - I'm on dialup. I cannot physically
disconnect the card because it is on the motherboard.

2. So how would it be done without Reshacking it?

3. You're welcome. Maybe you can add a version to your tweaks page as I'm
sure that there are others out there suffering the same unwanted icon.

This whole thing was a steep learning curve for me . . . a lot of firsts.
But the 'icon that wouldn't die' is finally gone, gone, gone!!! It's a
miracle.

BTW, if you can change this post from a question to a comment it would be
more appropriate - I clicked the wrong option when posting.

"Kelly" wrote:

> Hi,
>
> 1. Why is the lan icon x'd out? What are the circumstances?
> 2. As for the netshell.dll you probably didn't need Reshack to do it.
> 3. Thanks for the info.
>
> --
>
> All the Best,
> Kelly (MS-MVP)
>
> Troubleshooting Windows XP
> http://www.kellys-korner-xp.com
>
>
> "saynotogmos" <saynotogmos@discussions.microsoft.com> wrote in message
> news:0CBAAADE-4F16-43CE-BF98-620F06A2ABCE@microsoft.com...
> > Here is the fix for the x'd out LAN icon that just won't go away.
> >
> > ===============================================
> >
> > Fire up reshack and open c:\windows\system32\netshell.dll
> >
> > +Icon Group
> > |
> > |
> > |
> > 195
> > |
> > *1033
> >
> > right click on that "1033" and click "Delete Resource [Icon Group : 195 :
> > 1033]
> >
> > save it as netshell.dll.mod in windows\system32
> >
> > Boot into Safe Mode in command prompt. Type:
> >
> > cd\
> > cd windows\system32
> > del netshell.dll
> > ren netshell.dll.mod netshell.dll
> >
> > shutdown -r -f -t 01
> >
> > =================================================
> >
> > And voila! The dreaded x'd out LAN icon is gone for good and the system
> > tray works perfectly.
> >
> >
> >
>
>
>
Related resources
April 2, 2005 11:13:34 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

On my box the LAN icon is x'd out because "A network cable is unplugged".
It's not. I have a simple 2 computer LAN and the second box isn't always on.
If I turn it on the network is connected and the x goes away.
I mapped some of the drives on that second box, so when I start up in the
morning I get a second warning icon, this one for My Computer, telling me
that network drives are disconnected. This arrangement noticeably slows down
the startup because Windows is looking for the drives and LAN. Other than
that, no problems.
Do you think this setup could cause me larger problems? Do you know of a
better way to set up the occasional LAN?

"Kelly" <kelly@mvps.org> wrote in message
news:%23GMyQo3NFHA.2736@TK2MSFTNGP09.phx.gbl...
> Hi,
>
> 1. Why is the lan icon x'd out? What are the circumstances?
> 2. As for the netshell.dll you probably didn't need Reshack to do it.
> 3. Thanks for the info.
>
> --
>
> All the Best,
> Kelly (MS-MVP)
>
> Troubleshooting Windows XP
> http://www.kellys-korner-xp.com
>
>
> "saynotogmos" <saynotogmos@discussions.microsoft.com> wrote in message
> news:0CBAAADE-4F16-43CE-BF98-620F06A2ABCE@microsoft.com...
>> Here is the fix for the x'd out LAN icon that just won't go away.
>>
>> ===============================================
>>
>> Fire up reshack and open c:\windows\system32\netshell.dll
>>
>> +Icon Group
>> |
>> |
>> |
>> 195
>> |
>> *1033
>>
>> right click on that "1033" and click "Delete Resource [Icon Group : 195 :
>> 1033]
>>
>> save it as netshell.dll.mod in windows\system32
>>
>> Boot into Safe Mode in command prompt. Type:
>>
>> cd\
>> cd windows\system32
>> del netshell.dll
>> ren netshell.dll.mod netshell.dll
>>
>> shutdown -r -f -t 01
>>
>> =================================================
>>
>> And voila! The dreaded x'd out LAN icon is gone for good and the system
>> tray works perfectly.
>>
>>
>>
>
>
Anonymous
April 3, 2005 4:29:42 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

You could've done it with an icon editor or disable the net card in your bios
or *I think* use the hide inactive icons option.
Anonymous
April 3, 2005 4:29:43 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Yeah, disabling the NIC in the BIOS got rid of the icon but then my dialup
ISP wouldn't work properly. NIC needs to be enabled for some unknown and
illogical reason.

The hide options in the taskbar also didn't work as it kept resetting from
'always hide' to 'hide when inactive' at every reboot or wakeup.

Believe me, I tried everything through all the GUIs and nothing worked.

Thanks for trying though . . .

"Black Baptist" wrote:

> You could've done it with an icon editor or disable the net card in your bios
> or *I think* use the hide inactive icons option.
>
April 6, 2005 6:31:54 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Glad all is well and thanks for the feedback and will do! As per the
latter, am sure your post will handle that. :o )

--

All the Best,
Kelly (MS-MVP)

Signature changed for a moment of silence.
Rest well Alex and we'll see you on the other side.

Troubleshooting Windows XP
http://www.kellys-korner-xp.com


"saynotogmos" <saynotogmos@discussions.microsoft.com> wrote in message
news:837A67CE-BF81-40A0-A77F-EAA11296966F@microsoft.com...
> Thanks, Kelly.
>
> 1. The LAN icon was x'd out because I have a 1 gig ethernet card that
> isn't
> connected because I'm not using it - I'm on dialup. I cannot physically
> disconnect the card because it is on the motherboard.
>
> 2. So how would it be done without Reshacking it?
>
> 3. You're welcome. Maybe you can add a version to your tweaks page as I'm
> sure that there are others out there suffering the same unwanted icon.
>
> This whole thing was a steep learning curve for me . . . a lot of firsts.
> But the 'icon that wouldn't die' is finally gone, gone, gone!!! It's a
> miracle.
>
> BTW, if you can change this post from a question to a comment it would be
> more appropriate - I clicked the wrong option when posting.
>
> "Kelly" wrote:
>
>> Hi,
>>
>> 1. Why is the lan icon x'd out? What are the circumstances?
>> 2. As for the netshell.dll you probably didn't need Reshack to do it.
>> 3. Thanks for the info.
>>
>> --
>>
>> All the Best,
>> Kelly (MS-MVP)
>>
>> Troubleshooting Windows XP
>> http://www.kellys-korner-xp.com
>>
>>
>> "saynotogmos" <saynotogmos@discussions.microsoft.com> wrote in message
>> news:0CBAAADE-4F16-43CE-BF98-620F06A2ABCE@microsoft.com...
>> > Here is the fix for the x'd out LAN icon that just won't go away.
>> >
>> > ===============================================
>> >
>> > Fire up reshack and open c:\windows\system32\netshell.dll
>> >
>> > +Icon Group
>> > |
>> > |
>> > |
>> > 195
>> > |
>> > *1033
>> >
>> > right click on that "1033" and click "Delete Resource [Icon Group : 195
>> > :
>> > 1033]
>> >
>> > save it as netshell.dll.mod in windows\system32
>> >
>> > Boot into Safe Mode in command prompt. Type:
>> >
>> > cd\
>> > cd windows\system32
>> > del netshell.dll
>> > ren netshell.dll.mod netshell.dll
>> >
>> > shutdown -r -f -t 01
>> >
>> > =================================================
>> >
>> > And voila! The dreaded x'd out LAN icon is gone for good and the
>> > system
>> > tray works perfectly.
>> >
>> >
>> >
>>
>>
>>
!