Sign in with
Sign up | Sign in
Your question

HDMI Makes my PC > TV look terrible.

Last response: in Graphics & Displays
Share
May 24, 2012 10:30:40 PM

Have had this issue for years, I say years because I tried this a while back and just gave up and went back to VGA/DVI.
I currently mainly use VGA for my PC > TV connection, I am wanting to dual monitor and since I've got a GTX 550ti I cannot dual VGA. My problem is that I use VGA for my monitor (which still looks amazing) but then I put my HDMI into my tv and pc and it looks fuzzy, grainy, blurry and just all sorts of bad, I'm a gamer and the graphics just get wrecked when I have my HDMI plugged in.

Was just wondering why it's having these problems, I've been researching "googling" for the past few hours and even though there's been some good ones, I can't seem to get it looking just right.

TV and PC Specs as follows
Akai 32" TV - Shitty brand but it's what I've got.
I5 2500 - 4gb - GTX550ti (NvIDIA).

I have tried rescaling it to the "1920 x 1080 - 60Hz" as people have suggested, this just makes it looks a lot worse, Then I tried the Native which for my TV is 1360 x 768 and while it looks alright, it's still "fuzzy".

Some people suggested to rename my HDMI-1 Port to "PC" which I can not for the life of me find the option to do so on my tv, if it even allows such things. There was talk of overscaling and keeping it as a 1:1 ratio, which I get but can't seem to apply to my problem.

The text is fine, it wasn't for a long time but the icons (windows task bar) are fuzzy, games and graphics are fuzzy.
If this is just how it is, please just say so, don't want to waste much time with this, trying to have one monitor which is my TV for PC gaming ect and my other monitor (VGA) for movies.

More about : hdmi makes terrible

May 24, 2012 10:53:43 PM

You'll want to set it at your tv's native resolution (1360x768) and look through the nvidia control panel and make sure that it is set to progressive scan not interlace.
m
0
l
May 25, 2012 2:44:20 AM

CoolBOBob1 said:
You'll want to set it at your tv's native resolution (1360x768) and look through the nvidia control panel and make sure that it is set to progressive scan not interlace.

Looks better bad at the moment, really blurry and fuzzy.. anything else to try?

Also, a bit of the edges on the screen get blocked out (are off the edge) when I do this
m
0
l
Related resources
May 25, 2012 2:50:55 AM

1366X768 is usually the normal resolution not 1360X768, but if that don't work try the 1280X720, but i'm sure you have. Some TV can auto adjust to get it all to scale in nice. If your using a VIZIO you'll need to align the H and V properties. This is not to be mistaken with vertical and horizontal, as it makes things come in sharper i've no idea what actually means but my vizio has it.
m
0
l
May 25, 2012 2:54:04 AM

problem seems to be that your tv isn't true 1080P but 1080i, Not sure whose confused the graphics card or the TV but somewhere there seems to be a conflict. I'd once again go the settings, somewhere one of the two is confused on what 1080i is.
m
0
l
May 25, 2012 3:07:59 AM

mmilner1 said:
problem seems to be that your tv isn't true 1080P but 1080i, Not sure whose confused the graphics card or the TV but somewhere there seems to be a conflict. I'd once again go the settings, somewhere one of the two is confused on what 1080i is.

The TV (At Least what it said on the box) is 720p
m
0
l
May 25, 2012 3:22:45 AM

If I were to buy a HDMI > DVI adapter would it show much better results in quality? I do want to dual monitor but my graphics card will not accept dual vga and I guess this other than buying a new card would be my only option to do so.
m
0
l
May 25, 2012 5:32:19 AM

I couldn't find a manual for your tv, but you could try going through all the settings that involve zoom, 16:9, 4:3, cinema, if your tv is resizing your hdmi weird that might also cause some fuzziness
m
0
l
June 7, 2012 8:22:24 PM

The problem is with the type of signal being sent from/to the monitor. When your input is named/set to PC it sends the signal at a different frequency/power level. This will effect the quality of the image. I had the same exact issue when I switched over.

My resolution was to change the input/name to PC and turn overscan all the way up. My monitor looks perfect now. Just for reference I have a Samsung 2333hd and by setting the "hdmi" input value to "pc" the "blurriness" issue was immediately fixed. Turning overscan all the way up (0%) fixed the border issue.

Hope that helps. I know how annoying it is to search and search forever and not find a resolution. At least this may help someone searching down the road!
m
0
l
May 22, 2014 12:23:40 PM

NickleJack,

You deserve a freaking medal. It is beyond me that there isn't documentation detailing "Hey are you using a PC? Call it a PC in the name edit list of the sources. It actually makes a picture difference."

To state this differently so that future readers fully understand: It is now 2014 and this solution still works. If you are getting over-exposed, blurry text, generally bad images from your PC to your HDTV, go into the settings for sources and literally CHANGE THE NAME TO PC on that source, or a PC equivalent, and the TV will recognize this and change the way it processes the signal. Boom. Perfect image. Do not believe people that say TV's are not as good as PC Monitors - there are SOME things they are better at (sometimes refresh rate, black to black and grey to grey stuff, etc.) but having a terrible picture is not one of the weaknesses of a TV.

NickleJack = the best.
m
0
l
June 26, 2014 2:30:21 PM

BerretSO4 said:
NickleJack,

You deserve a freaking medal. It is beyond me that there isn't documentation detailing "Hey are you using a PC? Call it a PC in the name edit list of the sources. It actually makes a picture difference."

To state this differently so that future readers fully understand: It is now 2014 and this solution still works. If you are getting over-exposed, blurry text, generally bad images from your PC to your HDTV, go into the settings for sources and literally CHANGE THE NAME TO PC on that source, or a PC equivalent, and the TV will recognize this and change the way it processes the signal. Boom. Perfect image. Do not believe people that say TV's are not as good as PC Monitors - there are SOME things they are better at (sometimes refresh rate, black to black and grey to grey stuff, etc.) but having a terrible picture is not one of the weaknesses of a TV.

NickleJack = the best.


Could you tell me how to do this? I'm not super tech savvy so please try to keep it simple. Thanks :) 

m
0
l
June 27, 2014 4:26:29 AM

ToastedPotato said:


Could you tell me how to do this? I'm not super tech savvy so please try to keep it simple. Thanks :) 



Hey, Potato. This is going to be different with every TV, so you're going to have to apply this concept to however your TV is designed. The basic idea is:
IF you are using a TV with your PC, AND IF you get the problems with the picture as described in this thread, THEN:

Find wherever your TV menu/settings allows you to change the name for your input (e.g. "HDMI 1" or "Game" or "Cable" or "AVI" or "INPUT 2" or anything like that), and change that name to any option like "PC" or "Computer" or "Personal Computer." It could be that this is what is required in order for your TV to recognize that it is receiving a computer's input and fix the image.

If that does not work, keep looking for options that allow the TV to be in "PC Mode" or anything like that.
m
0
l
!