New build problem Help!

Hi I have just finished assembling my new pc however when I turn it on nothing is on the screen. The fans and the lights come on even the one on the cpu however my screen is just blank. I checked the monitor and it works fine for my other computer I'm checking all the connections however I'm out of my depth and could use some help at where to look.
4 answers Last reply
More about build problem help
  1. ZaneSeven said:
    Hi I have just finished assembling my new pc however when I turn it on nothing is on the screen. The fans and the lights come on even the one on the cpu however my screen is just blank. I checked the monitor and it works fine for my other computer I'm checking all the connections however I'm out of my depth and could use some help at where to look.


    ok here is a link at the bottom is what my build is http://www.tomshardware.com/forum/354148-31-building-gaming-less
  2. check that you have used the case standoffs and that the mb is not shorting out on the case. you may want to see if it posts outside the case with just the mb sitting on top of the mb box.
  3. took out the motherboard and ran it on the box still nothing. Did I connect something wrong or is the board damaged?
  4. some mb the first video is the onboard video..if your cpu and mb has it..try pulling the gpu and see if the onboard video works.
    a lot of times people miss the 4/8pin atx power plug near the cpu. or they dont put the mb case header wires on right and the mb is stuck in reset. also check that the cmos jumper is on the mb and in the right spot. the last issue would be a bent pin under the cpu or the cpu not installed right or not seated.
Ask a new question

Read More

New Build New Build Systems