Sign in with
Sign up | Sign in
Your question

Is my Sapphire 6870 DOA?

Last response: in Graphics & Displays
Share
May 27, 2012 12:15:36 AM

I inquired about a build earlier in the week and I got the parts a few days ago. I installed everything on Thursday night, and I started it up today.
The build is listed below:

- Intel Core i5-3570K 3.4GHz Quad-Core Processor
- ASRock P67 Extreme4 Gen3 ATX LGA1155 Motherboard
- Corsair Vengeance 8GB (2 x 4GB) DDR3-1600 Memory
- Seagate Barracuda 1TB 3.5" 7200RPM Internal Hard Drive
- Sapphire Radeon HD 6870 1GB Video Card
- Corsair CX500 Builder Power Supply

When I went to boot it up, nothing appeared on the screen. I had plugged in my monitor, which is an old Dell Widescreen LCD, via a DVI cable to the card. I thought the DVI cable might be faulty, so I used a VGA cable with a VGA to DVI adapter, and plugged it into the card. Again, nothing was showing. I finally gave up and plugged in the VGA cable to the motherboard (onboard graphics) and it worked. Another weird thing is that the DVI port on the motherboard doesn't work either.

Anywho, I thought it was just because I haven't installed the drivers yet, so I installed them via the supplied CD. I plugged in the DVI cable from monitor to card and nothing showed up. Downloaded the drivers straight from ATi/AMD and had the same result.

I thought the card wasn't seated properly, so I reseated it and then turned it on and got the same result. I even tried the other PCI-E port and nothing showed up either.

The onboard VGA will NOT work unless I remove the two PCI-E power plugs from the card.

Is the card DOA? Is my 500W PSU insufficient? If anyone else has questions about my process, please let me know.

Thank you!

More about : sapphire 6870 doa

May 27, 2012 12:35:50 AM

Really looks like the card is bad since you plugged both power leads to it and the motherboard shut of the IGP as it is supposed to.
The PSU should be sufficient and most likely you have a bad card!
m
0
l
May 27, 2012 12:42:37 AM

Did you plug in the power cable to the video card?

If the DVI port on the motherboard doesn't work either, it's possible the DVI cable is defective.
m
0
l
Related resources
May 27, 2012 8:50:03 AM

geekapproved said:
Did you plug in the power cable to the video card?

If the DVI port on the motherboard doesn't work either, it's possible the DVI cable is defective.


Yeah, I plugged in both 6 pin power plugs into the video card.

I will try to find another DVI cable. I used a VGA cable with an adapter and even that didn't work.

I will probably just send the card back for RMA.
m
0
l
May 27, 2012 2:53:36 PM

Well if it's the cable, your still gonna have the same issue if you send the card back.

The thing that tells me its the cable is you said you can't get DVI from the mobo either.
m
0
l
May 27, 2012 2:57:34 PM

But unlikely that both the VGA and the DVI cables are bad. Just make sure the adapter you use for the VGA cable is DVI-I not DVI-D.
m
0
l
July 6, 2012 2:28:41 PM

Hi, i have just about the same build as you do with the exception of the graphics which i bought a XFX radeon 6870 2gb, RAM which i bought gskill ripjaw Z, and a SSD along with my 1 terabyte drive. i seem to be having the same issues, also but it appears that my cpu fan wont turn, and that dr debug is saying i dont get past the intilization of the north bridge on the CPU. You should check to see if yours is running also, im gunna call asrock support n see if they can help if not, ill call intel, and if they shaft me im gunna RMA to new egg, ill post here again if i can fix it or if support is actually useful.
m
0
l
!