Sign in with
Sign up | Sign in
Your question

USB 2.0 Header Suddenly Won't Work

Last response: in Components
Share
November 30, 2012 8:54:34 PM

My case (ThermalTake AMD Edition) has a front panel with one USB2.0 port and one USB3.0 port. My motherboard has no USB3.0 headers (but two USB3.0 ports in rear). I have had the single USB2.0 front panel port connected to one of the 6 available internal header ports and was unhappy with only one of my case ports working. I installed a new USB3.0 PCIe card with 2 external and 1 internal USB3.0 port. I connected the front panel USB3.0 to the new header on the card (and also connected the 4-pin molex power connecter on the card). While I was rerouting these 2 wires, I unplugged a few of my other cords to reorganize, one of which was my front panel USB2.0 port connector.

I hooked everything back up, was pleased to find that the USB3.0 front panel port now works, but dismayed to find that my USB2.0 front panel port DOES NOT WORK ANYMORE. I pulled out my motherboard instruction manual to verify that I had the pin order correct - it is. I tried switching to a different one of the 6 available pin sets. Still no luck!

I don't get it! Help?

Specs:
CPU: AMD FX 4100 Black Edition
Mobo: ASROCK 970DE3/U3S3
BIOS: AMI
RAM: Corsair XMS3 8GB DDR3-1600 (PC3-12800) CL9 Dual Channel Kit (2x4GB)
PSU: Inland Gold Series ILG-400-2 400 Watt ATX
Graphics Card (Original): AMD Radeon HD 5450 512MB DDR3 PCIe 2.1 x16
Primary Hard Drive: OCZ Agility 3 120GB SSD
Secondary: Seagate Barracuda 1.5TB
OS: Windows 7 Pro
December 1, 2012 1:30:39 PM

Update: I tried plugging a front panel USB card reader into one of the aforementioned USB2.0 headers, and received no recognition from that device either.

Is it possible that all of my USB2.0 headers were damaged and rendered inoperable at once, while every other component on my motherboard remains functional?

CONFUSED!
m
0
l
December 1, 2012 2:48:31 PM

Update: I tried a system restore, and I tried loading BIOS defaults. Neither worked.

Is it my motherboard?
m
0
l
!