Sign in with
Sign up | Sign in
Your question

Radeon 6950 HD

Last response: in Graphics & Displays
Share
May 27, 2012 9:29:54 AM

Hey, i bought my computer xmas past and initially had trouble with the graphics card not being recognized but after posting on this forum i got it sorted,now i am having a similar problem. It was working fine till earlier today, then as i was playing worldoftanks the game froze so i had to reset my computer but the display went dead and it will only work when i take the hd cable and plug it into the old integrated graphics slot. I removed the graphics card blew any dust off and reset it securely back in its slot and nothing, the fans on the card are working, i went to display drivers to check but there is only the integrated graphics card option i am guessing its toasted but i said i'd check here before deciding what to do next.

More about : radeon 6950

a c 76 U Graphics card
May 27, 2012 10:53:13 AM

What is your PSU model? Cables are all plugged in? can you try a different output on the card? or do you have a second pcie16 slot? Have a buddy whose PC can handle it you can swap it into to see if its your board or something else?
m
0
l
a b U Graphics card
May 27, 2012 11:13:06 AM

unksol said:
What is your PSU model? Cables are all plugged in? can you try a different output on the card? or do you have a second pcie16 slot? Have a buddy whose PC can handle it you can swap it into to see if its your board or something else?

+1 i always blame psu first then motherboard and gpu an on level pegging for failure
m
0
l
Related resources
May 27, 2012 11:21:20 AM

unksol said:
What is your PSU model? Cables are all plugged in? can you try a different output on the card? or do you have a second pcie16 slot? Have a buddy whose PC can handle it you can swap it into to see if its your board or something else?


dont have anyone with a machine that i can try the card out on, the psu a 850watt something max, can't remember off the top of my head, its a poor brand but i remember checking it out before i got it and it was an old andyson (if i remember the name correctly) psu that was re-branded which was supposed to be fairly decent,the cables are in fine as far as i cant tell the 2 fans on the card are working fine. i have another pcie slot but its difficult to get to, there is some clutter there but i maybe able to get it in there, i tried earlier but it was 4am and maybe i was a little sleepy:) 
m
0
l
a b U Graphics card
May 27, 2012 12:10:06 PM

What is the brand & model of the 6950? Like unksol said, try in the other ports of the video card. I have similar experience with my Sapphire 6950 Flex where display will suddenly blink or go out of one port & it needs to be reset many times before it is able to display again.
m
0
l
!