Sign in with
Sign up | Sign in
Your question

Just bought a new video card But its not running right

Last response: in Graphics & Displays
Share
May 27, 2012 4:16:41 PM

Hello, So as the title says i went out and bought a new video card the other day, it ran right for a minute, but then it started to run worse then my Last video card which was a 512mb, My new one is a 2048MB Nvidia Geforce GT 430, Ive ran and updated the Driver as many times as i could, It still gives me the same problem as to where it runs Diablo 3 and World of warcraft worse then the last, The specs to my computer are
System
--------------------------------------------------------------------------------

Manufacturer Gigabyte Technology Co., Ltd.
Model 965P-DS3
Total amount of system memory 3.50 GB RAM
System type 32-bit operating system
Number of processor cores 2
64-bit capable Yes

Storage
--------------------------------------------------------------------------------

Total size of hard disk(s) 372 GB
Disk partition (C:)  77 GB Free (372 GB Total)
Media drive (D:)  CD/DVD

Graphics
--------------------------------------------------------------------------------

Display adapter type NVIDIA GeForce GT 430
Total available graphics memory 3583 MB
Dedicated graphics memory 2048 MB
Dedicated system memory 0 MB
Shared system memory 1535 MB
Display adapter driver version 8.17.13.142
Primary monitor resolution 1024x768
DirectX version DirectX 10

a b U Graphics card
May 27, 2012 4:26:17 PM

What was the model of your previous card?
m
0
l
Related resources
!