Sign in with
Sign up | Sign in
Your question

Acer aspire not picking up AMD RADEON 6500m

Last response: in Graphics & Displays
Share
May 28, 2012 3:51:54 AM

After not using my Acer laptop for sometime I decided I wanted to play skyrim on it, so I down loaded it from steam and under the menu to select the graphics processor it only shows my integrated card.

Under the device manager, it shows both my HD radeon and the integrated card, Under the bios settings the only graphics card related settings are if I want to do switchable of integrated, so it's on switchable.

I tried to go the amd and install the catalyst control center thing to perhaps install a newer driver, but when I try to download it, a message comes up saying that I have incompatible hardware/software on my computer. I have also tried this after using the driver sweeper to erase all the amd drivers.

I have gone into the amd settings and set skyrim to high performance and nothing.


I'm at a lost of what to do, so any help would be appreciated.
May 28, 2012 3:15:31 PM

I cannot find a setting to do that in the bios, I just updated the latest version off acer.com

m
0
l
June 1, 2012 5:43:45 AM

I am greatly interested in this case as well, as i also have an Acer Aspire that is not reading my Radeon 6550
m
0
l
June 1, 2012 6:28:16 PM

There are two ways to switch graphics on a laptop. One is to do it in the BIOS, the other is if your laptop has an actual physical switch that switches between the graphics chips. If your laptop doesn't allow you to do it through the BIOS - it's usually because there is a dedicated switch somewhere on your laptop. Look for it, or goto the manual to check where its listed as being.
m
0
l
Related resources
!