Sign in with
Sign up | Sign in
Your question
Closed

3D Vision disabled by default?

Last response: in Graphics & Displays
Share
May 28, 2012 7:10:34 AM

Is there a way to get 3D Vision disabled by default and I can turn it on when I want it just by pressing the button on the receiver? I've tried looking for this option in the settings and have not been able to find it.

Best solution

a c 80 Î Nvidia
May 28, 2012 3:40:48 PM

In the 3D Vision control panel, under "Set up stereoscopic 3D", enable "Hide stereoscopic 3D effects when game starts". Once in game, you can press ctrl-T to turn it on.

However, if you have "Enable stereoscopic 3D", even when it's off by default as I described above, or if you ctrl-T to turn it off, the drivers are still loaded and will incur some performance penalty.

What I do is I have an extended toolbar(just a folder that shows its shortcuts on the taskbar) with a couple batch files that enable steroscopic 3D and disables it. This disables and enables the driver support completely and has to be performed before I enter the game. With these batch files, when I turn it off, there is no performance penalty.

The script is very simple:
@echo off
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable
exit

And to turn it off:
@echo off
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable
exit
Share
May 30, 2012 3:41:28 AM

Best answer selected by Timoi.
Score
0
Related resources
May 30, 2012 3:41:47 AM

Thanks that was really useful.
Score
0
July 6, 2012 11:02:27 PM

bystander said:
In the 3D Vision control panel, under "Set up stereoscopic 3D", enable "Hide stereoscopic 3D effects when game starts".

There is no such option for me in the 304.79 driver.
Score
0
March 24, 2013 10:17:27 PM

bnot said:
bystander said:
In the 3D Vision control panel, under "Set up stereoscopic 3D", enable "Hide stereoscopic 3D effects when game starts".

There is no such option for me in the 304.79 driver.


same for me. no option and cant seem to get it working. I thinks its a problem with their drivers. on some previous release it was working but i don't know which version. checking one by one is too much trouble.
Score
0
a c 80 Î Nvidia
March 24, 2013 10:56:39 PM

It would seem the newer drivers no longer have the option, but as I mentioned before, it is best to turn off the 3D Drivers completely if you don't plan to use 3D in the game, as you lose 10% or more performance leaving them on. I outlined how to create batch files and putting them on the toolbar above, or you can find an app to do it (I found one before that worked).
Score
0
March 24, 2013 11:39:20 PM

The problem could in fact be the adapter as well.
Score
0
March 25, 2013 12:21:50 AM

bystander said:
It would seem the newer drivers no longer have the option, but as I mentioned before, it is best to turn off the 3D Drivers completely if you don't plan to use 3D in the game, as you lose 10% or more performance leaving them on. I outlined how to create batch files and putting them on the toolbar above, or you can find an app to do it (I found one before that worked).


i want to use the anaglyph 3d option but the problem is that stereo setup / wizard is not available in control panel even though 3d vision is installed. is there any option to manually run the wizard?
Score
0
!