Sign in with
Sign up | Sign in
Your question

Switchable Graphics Option in Catalyst

Last response: in Graphics & Displays
Share
May 28, 2012 5:07:48 PM

Hi i was told by EA over email to do this, to fix problems with my sims 3

Please Update your Video driver from the following website:
http://support.amd.com/us/gpudownload/windows/Pages/rad...

It's possible, the Sims3 is using your cpu's integrated GPU, to switch to your dedicated card, please open your Catalyst Control Center, and open Switchable graphics option. Add The sims3, Sims3 pets to the list, and switch to the high performance option.

Only problem is i can not seem to find the option, any help?

a c 143 U Graphics card
May 28, 2012 5:39:53 PM

What's your total system specs including monitor resolution?
And what problem are you specifically experiencing?
May 28, 2012 6:14:16 PM

Ati Radeon Hd 5700 series graphics card, 4gb Ram, 4cpu proseecor, direct X 11,

The problem i have is on the sims 3 there is a lot of flickering abnormal shadows on the sims themselves.
Related resources
a c 143 U Graphics card
May 28, 2012 6:18:31 PM

So you're using a discrete graphics card, not the Motherboard's internal graphics?
If so, uninstall AMD CCC, and download the latest version from the link u linked in the first post.
May 28, 2012 8:59:50 PM

On my device manager , under display adaptor there is just a the Ati radeon hd 5700 series card, i think they have got it wrong, because they think im playing on highest settings with no lag etc, so an intergrated card woulldn't be able to do that?
a c 143 U Graphics card
June 3, 2012 12:37:03 AM

IS your monitor cable hooked into the HD 5700 card? or directly to the motherboard?
June 3, 2012 4:41:32 PM

I am not entirely sure how to check, but i don't think that it is the problem anyway
!