Sign in with
Sign up | Sign in
Your question

Restore .cfg to default file association

Last response: in Windows 7
Share
February 2, 2012 3:17:22 AM

hi, have a .cfg file on my pc and i opened it with notepad but now its stuck to always opening with notepad. how do i turn it back to the unknown program as its default?

thanks windows 7 x64

tried the program called unassoc_1_4, but didn't help sadly :( 

hope someone can help.
February 2, 2012 6:24:02 PM

anyone?
m
0
l
a b $ Windows 7
February 2, 2012 6:39:06 PM

Notes
You cannot change an association for a file type or protocol and leave it blank or disassociated. You must select a new program.

The options you set here only apply to your user account. Your choices won't affect other user accounts on this computer.

The default file association for .cfg is nothing - so you can't change it again to nothing. You will have to create a new user account to change it back to default. Or possibly a system restore.

If you do decide to create a new account - make sure you back up everything on your old one.
m
0
l
Related resources
February 2, 2012 7:37:23 PM

man thats complicated, alrgith ill just prolly stick with it. :(  damn microsoft
m
0
l
a b $ Windows 7
February 2, 2012 7:59:25 PM

It's not that complicated.

Open up your control panel, then open user accounts. Click on user accounts, then click on manager user accounts.

Now add an account - give it full administrator priviliges.

Now what you can do is use the Windows Easy Transfer utility and save all your information to an external USB drive/key (do you have one?).

Once done - re-login with your new account and just transfer the files back using the windows easy transfer utility. It may say computer to computer - but you can easily transfer the information to the same computer.

Using this shouldn't copy the file association.


Orrr...you can just live with it :)  it's not really that big of a deal - is it? Do you play around a lot with CFG files?
m
0
l
a b $ Windows 7
February 2, 2012 8:02:29 PM

You can always try using system restore to an earlier date. In the start menu - type in system restore and open it up.

As long as you don't have it disabled you can restore it to the date before you changed the file association. That should fix it as well, and should be a bit easier than the method i described above.
m
0
l
a b $ Windows 7
February 2, 2012 8:03:41 PM

Hi :) 

Lol..you dont need to reload windows....just reassociate the .cfg file with the program its MEANT to be associated with...

All the best Brett :) 
m
0
l
a b $ Windows 7
February 2, 2012 8:15:07 PM

Brett928S2 said:
Hi :) 

Lol..you dont need to reload windows....just reassociate the .cfg file with the program its MEANT to be associated with...

All the best Brett :) 



Hey brett FYI - CFG files are not associated with any program (by default), and as i've stated already "You cannot change an association for a file type or protocol and leave it blank or disassociated. You must select a new program. "

And i've listed a few ways he can change it back without re-loading windows :) 
m
0
l
February 3, 2012 1:18:42 AM

ddint work rdg, still associated with notepad.

and it didnt make a restore point when i accidentaly made notepad associated with .cfg :( 
m
0
l
December 27, 2012 11:45:18 PM

For what it's worth... in the future change the .cfg file extension to .txt. Then edit the file as a test file in notepad, and save the .txt file. Then rename the file again, this time changing the extension back to .cfg. I know it's an old thread, but I came across it searching with Google as I'm sure other will. I just had to chime in and suggest people keep it real real simple. I hope someone finds the solution I'm offering here useful.
m
0
l
!