Sign in with
Sign up | Sign in
Your question

Radeon 6770 wouldn't work one my MOBO, but 6850 does, why?

Last response: in Graphics & Displays
Share
May 29, 2012 9:32:35 AM

Hello to all, i recently bought a XFX radeon hd 6770 1GB DDR5 for my gaming and 3d rendering. Some how the card does not give me any display at all, I have done all troubleshooting but now luck. What I have tried is; reset comos, set pcie to the default in bios, disable onboard graphics (intel 945g family chipset), tried to install driver but is does not pick up that the device is in. The card works fine with my friends system and he runs a HIS radeon 6850. The funny thing is that the 6850 he has works fine on my system, it gives display as soon as the computer turns on. The mother he has is a higher asrock wolfdale with four memory slots, mine has two memory slots.

Before buying any motherboard, I wanted to see if any one here can help me with this weird situation.

My specs are:
160GB hard drive space
2.00ghz intel pentium Dual core
2.00Gb DDR2 memory
Asrock wolfdale 1333-d667 MObO with intel 945g integrated graphics
MOBO pcie version v1.0
PSU Antec earthwatts 650w, 80 plus broonze

Please help here, thanks
a c 125 U Graphics card
May 29, 2012 9:57:43 AM

Hi

Does your motherboard have the latest supported BIOS?
m
0
l
a b U Graphics card
May 29, 2012 9:58:33 AM

Does the graphics card spin up in your computer?
m
0
l
Related resources
May 29, 2012 1:38:08 PM

Rustyy117 said:
Hi

Does your motherboard have the latest supported BIOS?



I'm running a win7 ultimate on it...i checked the asrock site for bios update but they only have for vista and xp :( 
m
0
l
May 29, 2012 1:39:19 PM

adam_x_brookes said:
Does the graphics card spin up in your computer?


yeah the fan spins well in my mobo and my friends too
m
0
l
a b U Graphics card
May 29, 2012 5:17:32 PM

why dont you rma the crd?
m
0
l
May 30, 2012 1:40:48 AM

"rma" what you mean by that?
m
0
l
a c 125 U Graphics card
May 30, 2012 7:23:10 AM

You'll have a differcult time returning a product as faulty if it works in your friends PC...
m
0
l
a c 99 U Graphics card
May 30, 2012 7:44:33 AM

I would suggest, uninstalling the graphics driver on the card and re-installing the graphics driver. Also try another PCI-E slot.
m
0
l
May 30, 2012 1:16:04 PM

Sadly I have done that (well disable it) and same thing, could not install the driver from the disc it says go to xfx.com when i do that i only got the catalyst thing, install that but nothing and even more sadness i only have one PCI-Ex16 slot :( .

Thinking of getting a new motherboard, but might look for a combo first that fits my budget (100-150USD)...any ideas where is the best place in your opinion.
m
0
l
a c 99 U Graphics card
May 30, 2012 11:56:15 PM

Don't install drivers from your xfx disc. Go directly to amd.com and go to the driver page.
m
0
l
!