Sign in with
Sign up | Sign in
Your question

Thermaltake gt10 Front Power Button

Tags:
  • Power Supplies
  • Power
  • New Build
  • Components
Last response: in Components
Share
December 3, 2012 8:43:47 PM

hi having problems with my power case button this is a new build about 1 1/2 months old. long build waiting for parts having the time to do it etc. Anyways the last 2 weeks it has been up and running with no problems but just kinda had stuff slapped together while waiting for the rest of the stuff to arrive so it finally did got everything installed tested it for a few days and still no problems even have windows installed and been fiddling and tweaking that the last week. So now figuring ok its done and I'm happy with everything so I do some quick cable management to get them tightened down they have been just kinda hanging out in the open. Didn't unplug anything except the 24 pin the 8 pin and my graphics card power to adjust them so I could get the side panel on now my power button is all the sudden acting up quit a coincidence that it does this then, so I would assume its my fault somewhere I check all my connections cant see anything partially plugged in or in the wrong spot take the front panel off and the power button connections look fine nothing broken. Except once when it wasnt working I gently pressed the power button wires in and it clicked on, on me and worked for like 5min then poof quit again.

So here,s what its doing I can turn the power on/off with the psu everything comes up and runs no problem fans, sdd, hdd's, gpu, sound card etc. I can depress the power button on the front panel to turn it off but It wont start up the machine and if I do turn it off through the power button it will turn itself back on again like 3 seconds later same if I turn off the machine through the windows start button it will just come right back on. I checked my power plan setting spent about 8 hours checking all the plug-in's yesterday to no avail emailed thermaltake support still no reply as of yet. I'm sure this is my fault somewhere as I said worked perfect for a few weeks until I decided to tighten a couple cords down to get them out of the way so my side panel would close now all the sudden poof just I can't find the problem whatsoever any ideas?

More about : thermaltake gt10 front power button

a b ) Power supply
December 3, 2012 11:50:59 PM

Yea it definitely sounds like a flakey power switch. Contact thermaltake for a replacement.
m
0
l
!