Sign in with
Sign up | Sign in
Your question

Skyrim Low Performance Fix?

Last response: in Graphics & Displays
Share
May 30, 2012 9:40:40 PM

Ok, I think I just figured out how to play skyrim with silky smooth performance. I've tried quite a few things, including disabling crossfire, putting the graphical settings on low(turning off aa and such). Ok, maybe just a couple of things. Anyway, setting Skyrim to run in windowed mode seemed to do it for me. Now, before you say it's because that disables crossfire, I had already disabled crossfire in the ccc. So what sense does that make, exactly? Knowing what setting to use gets me no closer to knowing why I get such crappy performance in fullscreen. If you look at my specs, you should come to the conclusion that I should be able to run on ultra settings while in fullscreen. I guess I should just be thankful I got rid of the jittery, stuttery turning and whatnot. If anyone knows exactly what it does putting it in windowed mode, other than disabling crossfire, we could be one step closer to figuring out why it runs like that in fullscreen.
May 30, 2012 10:51:45 PM

the game engine has some funky 64Hz clock thingie going on that causes the stuttering, even when it's hitting stable 60fps. The stuttering goes away in 3rd person mode, also if you use a fps limiter at 60fps while disabling vsync in the .ini setup files, and finally the 3rd known solution is to run the game in windowed mode (there even is a 'borderless window' mod to make it look like fullscreen...

so congrats for finding nothing new...
m
0
l
May 30, 2012 11:10:47 PM

That's strange.

I've only got an HD5870 and I can play basically maxed (without HD textures) at 60FPS.

No stutter.

I wonder what would happen if you physically removed one of those cards. I know that's not ideal; it's just a step in the troubleshooting process.

You could also try using RadeonPro, such as:

1) drag over Skyrim exe to RadeonPro
2) disable VSYNC in the Skyrim ini file
3) run Skyrim and check the frame rate (RadeonPro can show this)
4) assuming it is over 60FPS, then..
5) enable VSYNC in RadeonPro

Basically I'm suggesting trying RadeonPro's VSYNC instead of Skyrim's. Not sure why it would matter but it's the only thing I can think of.
m
0
l
Related resources
May 30, 2012 11:37:35 PM

Appreciate the fast responses, albeit a tad rude. The question mark at the end of my thread should suggest to you that I wasn't really sure if it was a solution or not, henceforth, I'm not really proud of my "nothing new" discovery. Appreciate the congrats though, didn't mean to get anyone's hopes up. It seems the "solution" has made it run worse outside, but super smooth inside. I'll try the radeon pro thing, thanks for the suggestion. Pulling the second card is starting to sound ideal, given the amount of money spent to get sub-standard results. That's just about every game I play. It seems Witcher 2 is the only one that scales properly.
m
0
l
June 6, 2012 5:47:31 AM

which .ini file has the vsync option? location?
m
0
l
June 7, 2012 10:31:11 PM

\My Documents\My Games\Skyrim
SkyrimPrefs.ini
under the [display] section change the line to 0
iPresentInterval=0

also add that line into the skyrim.ini file under display as well.
But use some fps limiter or the physics might go wild... dxtory should work with amd cards, set it to 60 or 59.

though some say just having dxtory up an running and showing the fps in-game (also the limiter set to 60 but not enabled) reduces the stuttering while still having iPresentInterval set to 1...

edit dxtory is primarily a capture tool but has some extra features as well
http://dxtory.com/v2-home-en.html

edit 2
http://forums.bethsoft.com/topic/1329260-b1gbaddaddys-b...
check the 2.1 section, some info seems to be gathered there, not sure if it is up-to-date anymore... (the game has version 1.6 beta available...)

edit3
also some say that just having fps capped at 57-59 fixes it with no side effects (having iPresentInterval at 1)

yeah it's a mess


edit4 also my favourite: get a 'good' wired mouse, some wireless mice can give some extra stuttering of their own. I just tested this and with the wired MS optical mouse from my secondary rig I get smooth gameplay without any tweaks, compared to my wireless logitech that causes some stuttering it seems. lol.. *banghead* funny thing thou, havent noticed this in any other game i've played...
m
0
l
June 8, 2012 9:25:02 AM

Thanks Kari, I am going to check out dxtory and capping at 59. It is messy. Seems I spend more time trying to tweak than actually playing. Heh heh.
m
0
l
June 9, 2012 7:36:55 AM

Well, this is kinda strange. I just got my new 3D monitor in the other day and have been tinkering around with a few things. Not to get into to much detail, I was able to turn on fullscreen and go crossfire with ultra settings and the weird jerky turning motion is completely gone. I have vsync disabled, but I don't really have to worry about screen tearing since it rarely goes over 120fps. Crossfire doesn't really seem to scale as far as fps goes, but I did notice the fan on one of my cards kick up, and I never really heard it do that with Skyrim before. This may be because the cards are actually allowed to render more frames now, I don't know. Now, thanks to sub-standard crossfire performance, all I have to worry about is low fps when viewing long distances with many objects on screen.
m
0
l
!