Sign in with
Sign up | Sign in
Your question

New-built system trouble, and I need your help.

Tags:
Last response: in Systems
Share
July 23, 2012 10:46:08 PM

Hello everyone, I am a new member here. I just built a new computer system by myself. This is my first time to build a system too. :) 
This is the components of my system:
1. PSU OCZ Modxstream pro 700 W.
2. HDD western digital caviar blue 500 GB SATA 6.0Gb/s.
3. Case cooler master HAF 912.
4. ASUS 24x DVD Burner.
5. Motherboard Asrock 990FX Extreme3.
6. CORSAIR Vengeance 16 GB, DDR3 1600.
7. Graphic card: GTX 480.
8. AMD chipset: AMD 4100 fx.

I installed all the components successfully. I checked all of the cables. However, when I plugged in the psu, my motherboard does not work. I do not see any lights on it. I did check the pin of power switch and the reset. I tried to reverse the pins, but it still does not work.

I tried to connect a case fan directly to the psu, and the fan does not work neither. I am thinking about return the psu and get the PC Power and Cooling Silencer Mk II 750W. Because it has long cables. So, it is easier for me to manage the cable, and that is a good psu too.

So, what are your opinions about the trouble I am facing now?

I am looking forward to receive your replies.

Thank you in advance, and have a nice day. :) 

More about : built system trouble

July 24, 2012 1:28:04 AM

cranked said:
Have you flipped the switch on the back of the PSU to 'on'?

You could try the paperclip trick to see if the PSU will turn on.
http://www.overclock.net/t/96712/how-to-jump-start-a-po...

Also, check the outlet you are using is alive.


Thank you Cranked, I did flip the switch on the back of the PSU to 'on', and the outlet I am using is very good because I use it everyday to charge my cell phone.

When I plugged it the psu to the wall, I do not even see the fan on the psu running, does that mean the psu died?
m
0
l
Related resources
July 24, 2012 1:33:10 AM

Quote:
If is indeed a bad psu, I suggest Seasonic or Corsair psus.


Thank you, Jallenlabs. That is the Corsair psu, and I did purchase the psu at newegg. Maybe I am not lucky at this time.
m
0
l
August 7, 2012 8:33:00 AM

Thank you everyone. I did solve the problem. I dont know how I did it. I just took the CPU, the PSU out, then re-installed them again, and it works. :) 
I appreciate everyone's help.
Have a nice day. :) 
m
0
l
!