New Motherboard + CPU; Lights briefly then nothing

I just bought a new Z77 Pro 3 motherboard and an i5 3570k. I installed both. Everything is connected, including a new stick of 4 GB DDR3 RAM. I'm using a Corsair 650W power supply.

I have a USB hub and an audio interface connected to the motherboard. What they are doesn't matter - when I flip on the power switch (from 0 to 1) on the back of the PSU, they both light up for about a second, then turn off. The power button does not turn on the computer and I am sure I attached the jumpers to the right areas.
2 answers Last reply
More about motherboard lights briefly nothing
  1. An update:

    Did everything on the checklist.

    New parts:
    ASROCK Z77 Pro 3 Mobo
    i5 3570k
    One stick of 4 gb Corsair RAM

    Old Parts: Unlocked 6950
    2 x SATA 250 GB Hard Drives
    Coolermaster 650W PSU

    Installed these things today. Here's exactly what has happened so far.

    1. Installed everything, turned on computer - any usb devices connected to the computer lit up for a brief second. Computer would not turn on.
    2. Fixed the jumpers, as I had accidentally put the power jumper on the reset jumper spot on the mobo.
    3. Computer now turns on, fans run; however, it runs for about 5 seconds then shuts off, then turns on again. There is still no display.
    4. Reseated the RAM, now here I am. Computer runs, fans and LEDs turn on, but no display. Double checked all wires and connections.
    5. Followed checklist.
    6. In addition to the checklist, I tried plugging my monitor into the onboard video. There is still no display.
  2. It sounds like either your CPU or motherboard is damaged. The odds are it's your motherboard, so I'd RMA that first (unless you have another Z77 motherboard kicking about you can test it on).

    Also, as an aside, you should really have 2 sticks of RAM in your system to get the benefit of DDR.
Ask a new question

Read More

Homebuilt Motherboards Systems