Restore Image Preview as Default Action?

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Somehow the default action for images in my desktop context menu was changed
to Open. The Preview option is still there, it's just not the default. How
can I make Preview the default action?

I tried editing the registry key
HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\
ContextMenuHandlers\ShellImagePreview but that only had the effect of
removing or restoring the Preview option from the context menu; it didn't
have any effect on which action is the default.
2 answers Last reply
More about restore image preview default action
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Hi Steve,

    If you've used the open-with option for that file-type and chosen "Windows
    Picture and Fax Viewer" permanently, "open" action becomes the default. Open
    Folder Options applet, and switch to File Types tab. Select the file type
    (example.. .JPG) from the list, and then click "Restore". Click OK to close
    the dialog.

    Or, edit the registry and delete the "ProgID" and "Application" values in
    this key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jpg
    (Assuming for .jpg files)

    Then, type this in Start-Run if needed:

    regsvr32 /i shimgvw.dll

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "Steve J." <Steve J.@discussions.microsoft.com> wrote in message
    news:48FA780F-4A2F-4307-8092-5A69A7EA2E12@microsoft.com...
    > Somehow the default action for images in my desktop context menu was
    > changed
    > to Open. The Preview option is still there, it's just not the default. How
    > can I make Preview the default action?
    >
    > I tried editing the registry key
    > HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\
    > ContextMenuHandlers\ShellImagePreview but that only had the effect of
    > removing or restoring the Preview option from the context menu; it didn't
    > have any effect on which action is the default.
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    >> chosen "Windows Picture and Fax Viewer" permanently

    Any other application / third-party viewer.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    news:e%23bkRUVQFHA.3560@TK2MSFTNGP14.phx.gbl...
    > Hi Steve,
    >
    > If you've used the open-with option for that file-type and chosen "Windows
    > Picture and Fax Viewer" permanently, "open" action becomes the default.
    > Open Folder Options applet, and switch to File Types tab. Select the file
    > type (example.. .JPG) from the list, and then click "Restore". Click OK to
    > close the dialog.
    >
    > Or, edit the registry and delete the "ProgID" and "Application" values in
    > this key:
    > HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jpg
    > (Assuming for .jpg files)
    >
    > Then, type this in Start-Run if needed:
    >
    > regsvr32 /i shimgvw.dll
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "Steve J." <Steve J.@discussions.microsoft.com> wrote in message
    > news:48FA780F-4A2F-4307-8092-5A69A7EA2E12@microsoft.com...
    >> Somehow the default action for images in my desktop context menu was
    >> changed
    >> to Open. The Preview option is still there, it's just not the default.
    >> How
    >> can I make Preview the default action?
    >>
    >> I tried editing the registry key
    >> HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\
    >> ContextMenuHandlers\ShellImagePreview but that only had the effect of
    >> removing or restoring the Preview option from the context menu; it didn't
    >> have any effect on which action is the default.
    >
Ask a new question

Read More

Configuration Default Microsoft Customization Windows XP