Need Help with Video Card!

Hey guys,
I just recently purchased a EVGA GTX 670, installed it, downloaded the most up to date drivers from the website and restarted by computer. After windows loads to my desktop my screen goes RED! What Happened is the card defected? My 570 was working just fine, and i have never experienced a red screen before. please help
5 answers Last reply
More about need video card
  1. have you completely uninstalled the 570 drivers?

    Uninstall the driver completely, then take out your gtx 670, try a differenct pci express slot if you can. and then put it back in. Install the drivers again. If it doesn't solve the issue, then RMA.
  2. the bottom pci express will load with no problems, then i switch back to the top one red screen again, yes i did unistall all drivers and reinstall
  3. RealTyler25 said:
    the bottom pci express will load with no problems, then i switch back to the top one red screen again, yes i did unistall all drivers and reinstall


    yeah its probably because the bottom one is a pci express x16 slot and the top one is a 8x. So your gpu is not transferring enough bandwidth from the motherboard. Or its simply a motherboard issue unless your gtx 570 was running fine on the top. Also another explanation might be gtx 670 requires pci express 2.1 slot maybe the top one isn't.
  4. yep 570 ran fine on top, the mobo is asus sabertooth p67, i was thinking its some sort of driver problem
  5. RealTyler25 said:
    yep 570 ran fine on top, the mobo is asus sabertooth p67, i was thinking its some sort of driver problem


    yeah quite possible..but you can just leave the gpu on the bottom slot and let it stay there for now. If its a sabertooth that means both slots are pci express x16 so there won't be any difference in performance.
Ask a new question

Read More

Graphics Cards Graphics