Sign in with
Sign up | Sign in
Your question

Clean install of windows 7 getting a black screen

Last response: in Windows 7
February 2, 2012 8:00:53 PM


I just did my first build and I am having a big problem with installing windows 7 on it. When I boot it's starts loading and then I get a black screen. I didn't get any options before or any command.

my build:
CPU: Intel i7-2600
PSU: Corsair TX650
RAM: Corsair DDR3-1600 8GB

At the first start up of the machine everything was fine I got the BIOS, did a few changes then went to reboot to install windows 7. Problem started ^^

I tried a few changes, like in the SATA configuration. It was on AHCI mode I put it on IDE. I tried connecting my screen with a VGA cable because I read HDMI was bugging. I tried installing 32bits version.

I am pretty noobie about all the configuration on BIOS so maybe it's a simple fix, I don't know.

I'm stuck with this black screen and could find my answer on any forum. I would really appreciated if someone could help me out :) 
a b $ Windows 7
February 2, 2012 8:18:41 PM

I would probably either go into the bios and reset all to the baseline or clear the cmos (bios) by disconnecting power and moving the cmos clear jumper to clear and then back, then go into the bios and set the correct settings for some things like your memory (seems to often be an issue using spd), also do use ahci sata mode, and if your card has DVI slot, use it to connect your monitor.

Disconnect any drives other hard drives than your boot drive for Windows setup.

Also in your bios, go to advanced mode (upper right corner), then select the boot tab -- disable full screen logo, setup mode to advanced.

If you initially installed Windows in AHCI mode, you cannot just change the bios setting to IDE because the drivers will be incorrect, so that could be an issue.

Also run a memory test to check your memory.
a b $ Windows 7
February 2, 2012 9:53:52 PM

Hi :) 

The above poster is correct.....its the IDE/AHCI setting in the bios...change it back to AHCI and your problem should be cured...

All the best Brett :) 
February 3, 2012 7:34:28 AM

Thanks for the replies :) 

Actually the problem was fixed when I turned off the TPU ^^