Sign in with
Sign up | Sign in
Your question

Cant run .bat files in windows 7 x32 with uac disabled

Last response: in Windows 7
Share
February 2, 2012 8:20:31 PM
February 2, 2012 8:48:27 PM

Um explain in forum don't use e-mail we need more info such as what does it do when you run the batch file?

Thent
m
0
l
a b $ Windows 7
February 3, 2012 11:25:04 AM

Try opening a CMD window and executing the bat file from within it.

Also, there is no reason to disable UAC in Win7.
m
0
l
Related resources
February 3, 2012 4:26:42 PM

Sorry for the vageness of the first post.
im trying to run a .bat file to execute a script in paradox 4.0


@echo off
cls
cd\test
paradox




paradox is on the c drive "not inside program files"

c:\pdoxrun
c:\pdox40\paradox
c:\test


i disabled uac because its annoying. i know how to run as administrator from the advanced tab on a shortcut , and from the .bat itself.
i can run paradox from the cmd.
i need a way to launch a script in paradox with having to go into paradox , changing the directory, and running the script.
several employees use there scripts. and dont know how to navigate through paradox.
m
0
l
February 3, 2012 4:58:14 PM

What drive is your profile on? If its redirceted via GPO then you Command window may launch on that drive and not C:
If this is the case just add a the drive after the cls so it reads

@echo off
cls
C:\
cd\test
paradox

But reading you batch file you are tring to launch a program or batch file called paradox in the C:\test folder. is this correct or are you tring to launch a script called paradox?
m
0
l
a b $ Windows 7
February 3, 2012 5:07:12 PM

Quote:
cd\test


I'm reasonably sure this is incorrect DOS syntax? Looks like you are trying to navigate to the test directory on the c drive, which I typically would write as:

cd\ [go to root directory, IE C:]
cd test [go to C:\test]

Then again, its been years since I had to break out my DOS syntax, so I'm a bit rusty...
m
0
l
February 3, 2012 6:04:35 PM

tried both
i still get paradox is not an internal or external command.....
and yes cd is change directory cd is not a folder on the c drive

im trying to launch a script within the test folder
m
0
l
February 3, 2012 6:41:24 PM

what is the name of the script you wish to launch
m
0
l
a b $ Windows 7
February 3, 2012 6:41:42 PM

Quote:
i still get paradox is not an internal or external command.....


So that means that it isn't picking up the .exe file. Make sure its in the test directory. If it is, try launching with paradox.exe instead of just paradox.
m
0
l
February 3, 2012 9:30:08 PM

ok we got it! the problem was the paradox exe. needs to be in the same folder the script is in. so i copyed the pdox40 contents into the test folder and BAM it worked!
thanks guys!
m
0
l
!