Sign in with
Sign up | Sign in
Your question

Help needed with assebling a PC

Last response: in Systems
Share
July 26, 2012 7:13:10 PM

I need help with assebling a computer. I bought an NZXT Phantom, Z77A-GD65, i5-3550, OCZ Fatal1ty 750W, ASUS GTX 670 CU II and G.Skill 8GB RAM.
I have placed the mobo in the chassis, installed the PSU, CPU and RAM and put in the GTX. However i am stuck now. I have no idea how to connect the GTX to the PSU (I have two molex cables that end with 6 on one side and 6+2 on the other) The GTX has 2x6 pins, so i am assuming that the PSU-GTX connection is 6-6 with the +2 just dangling around. I also have no idea how to properly connect the mobo to the chassis via the wires. Some of the Phantoms cobles fit nowhere on the GD65. Can anyone advise ? And do not refer me to the manuals. These suck. Example: GTX "manual" tells me to put the card in the PCI or AGP slot. And it shows a picture of a decade old card. Proper power coupling is not cevered beyond: "If needed, do it".

More about : needed assebling

July 26, 2012 7:50:11 PM

put the 6 pins to 6 pins for gtx and look on youtube on how to connect power/reset/hhd/pw or look in motherboard manual for connections
July 26, 2012 8:49:29 PM

Thanks for the reply. Solved some of my problems, but here's the biggest one yet. The computer starts but then immiedlity shuts down. CPU and chassis fans start, some LEDs go off, but less than a second later it turns off. No sound cues, no smoke either.
Related resources
July 26, 2012 8:52:02 PM

did u connect the 4pin 12v connecter for the cpu?
July 26, 2012 8:57:35 PM

if you have connected the cpu power i would try starting it with just essential stuff connected (cpu, 1 stick of ram, etc) to see if it just works. from there you could connect another item each time to try and troubleshoot which one might be problematic. It could also just be a bad psu
July 26, 2012 9:11:34 PM

Everything basides the mobo and CPU are disconnected (1RAM stick). Still the same. This was a long day, so i'll try tommorow after i wake up and try the PSU from this (the old) PC. Will keep you updated.
July 26, 2012 9:39:24 PM

Ok, i had to try. Used the old and working PSU. No effect. Momentarily shuts down after starting.
July 26, 2012 9:43:35 PM

Cannot edit. Using an 8pin plug. Is that bad ?
July 26, 2012 10:18:08 PM

First, i appologize for bumping, but as i said, i cannot edit my posts.

Here's what i did. As daswilhelm ask if i used the 4pin connector, i realized i used the 8pin. So i went and switched. But as the PSU has a 20+4, an 8pin and a 4+4pin i didnt know which 4pin of the two to use. So i picked one with 2black and 2yellow-green cables in it (other one has 2black and 2yellow). So i plugged the PSU to the power and switched it on (just the PSU, not the whole PC). And then something clicked about 2m away from me. The PSU light up with its diod and wnet silent. Now nothing works. I think that i have broke the PSU.
Also i am using a power cable diffrent from the one supplied with the PSU (original has an american connector, so i cannot use it and am using a cabel from a difrent PSU; the original has 13A written on it and i am using a 15A cabel).
!