Sign in with
Sign up | Sign in
Your question
Closed

Shogun Total War 2 display Crash

Last response: in Graphics & Displays
Share
June 4, 2012 1:55:13 AM

I have just recently built my gaming rig and bought "Shogun Total War 2: Fall of The Samurai" for it. It was running on all ultra graphics on Dx11 with no lag at all, but later on(about 2 days later) it started doing these very strange crashes that suddenly froze up my screen for a bit and then the display for my game goes completely transparent, like I am on the tab but there is no display for it. Also on top of that when i'm on the "Shogun Total War 2" tab my cursor is the cursor you have in-game. It will happen in the main menu, the campaign map, battles ANYWHERE! I should also say that I only have "Shogun Total War 2: Fall of The Samurai" and not the full game. I have been able to run Empire, and Medieval 2 Total War with no crashes as well. I have tried updating my drivers ,re-downloading the game, and updating Dx11 but to no avail. I can run the game on Dx9 on ultra settings and when it gets to part where the screen freezes up it will go to a loading screen and it will shortly return to my game. This makes me very angry because I spent about $1000 on this new PC and I would like to enjoy this great game. I would very thankful to anyone who could help solve this corundum.
a c 99 U Graphics card
June 4, 2012 7:09:51 AM

Can you list all the specs of your computer?
Score
0
June 4, 2012 5:48:06 PM

Graphics card- EVGA GeForce GTX 550 Ti SuperClocked 1GB GDDR5

CPU- AMD Phenom II X4 965 Black Edition AM3 CPU

RAM- Patriot Gamer 2 4GB DDR3 PC10666 1333MHz

Motherboard- ASUS M5A97 AMD 970 Socket AM3+ Motherboard

Hard drive- WD Caviar Blue 500GB SATA HD 7200/16MB/SATA-6G

Disk drive- Sony Optiarc 24X DVDRW SATA OEM

Power Supply- Cooler Master Elite Series 460W Power Supply

Case- Cooler Master Elite 430 Mid Tower ATX Case

that is all and thanks alot for replying!!
Score
0
Related resources

Best solution

a c 99 U Graphics card
June 4, 2012 8:14:37 PM

There are known issues with fall of the samurai. Hopefully, there should be a patch coming out. In the meantime, have you updated your BIOS? Have you done any overclocking?
Share
June 5, 2012 1:41:20 AM

I will check into updating my BIOS, and as for overclocking I have done nothing of the sort. I forgot to mention that my CPU's temps in-game are over 60C, and my GPU's temps are usually over 60C as well.
Score
0
a c 99 U Graphics card
June 5, 2012 1:42:27 AM

All is good, nothing wrong with your card. Just the game has issues.
Score
0
June 5, 2012 1:53:09 AM

That is good to know I hope they come out with an update soon and thanks for the help good sir.
Score
0
a c 99 U Graphics card
June 5, 2012 1:53:50 AM

No problem :) 
Score
0
June 5, 2012 1:58:42 AM

Best answer selected by PwncakesNRofls.
Score
0
!