Sign in with
Sign up | Sign in
Your question

HD 6870 PCIe issue

Last response: in Graphics & Displays
Share
June 4, 2012 9:12:20 AM

I just rebuilt my desktop computer and my graphics card will only work in the PCIe x4 slot, on the x8 and x16 the monitor shows up black. Any help on how to get it to work on the x16 slot will be greatly appreciated.

System:
OS: Windows 7
GPU: Sapphire HD 6870 1G
Motherboard: GIGABYTE GA-Z68MA-D2H-B3 LGA 1155 Intel Z68
RAM: CORSAIR Vengeance 8GB DDR3 1600
PSU: SeaSonic X750 Gold 750W
CPU: Intel Core i5-2500K

More about : 6870 pcie issue

a c 76 U Graphics card
June 4, 2012 9:47:45 AM

You absolutely should not have to do this but maybe its glitching. Have you tried setting the pcie to be primary and/or disabling the integrated GPU I. the BIOS? if so I'd do a BIOS update if still nothing RMA the board
m
0
l
June 4, 2012 10:35:49 AM

I disabled the integrated GPU but it did not work. Just to check I just put in my old 4870 in the x16 slot and it works fine.
m
0
l
Related resources
a c 76 U Graphics card
June 4, 2012 10:42:15 AM

hmm. that's really strange. I don't suppose you have another system with an x16 slot you can try it in? maybe one of the back signal paths is damage or something, and when its in a x4 slot it doesn't try to use it? random guess
m
0
l
June 4, 2012 10:53:46 AM

I currently do not have another system with a x16 slot unforchanately but I was going to try and see if I could find a friend who would let me try it on their system. This however is unlikely since most are out of town for the summer.
m
0
l
!