Sign in with
Sign up | Sign in
Your question
Solved

Problem with amd radeon hd6770

Last response: in Graphics & Displays
Share
June 6, 2012 12:36:47 PM

i have a problem with amd radeon hd6770 , the CCC don't want to load up when click on the CCC at the desktop , any help would be most appreciate, thanks. below is my system:

processor: core i 5 2400
mainboard: asus PBH67-M LE
ram: 8 gigs
power supply: 600watt
hard disk: seagate barracuda 1000gigs

Best solution

June 6, 2012 1:03:53 PM

hi cheehieng,

What driver are you using? Have you been able to get into the CCC before?

I would start by completely uninstalling all AMD drivers (using atiman uninstaller) and then install drivers fresh.

If you are uncomfortable using a 3rd party utility, you can follow these steps as well:
http://www.overclock.net/t/988215/how-to-properly-unins...

The default AMD uninstaller is really bad
Share
June 6, 2012 3:43:03 PM

I'm using the driver that installed from the CD that come with the graphic card, it can be

load and working at the first time but its lagging, and then 2nd time it wouldn't load

again.


After looking at the guide that you supply , i first uninstalled the driver, together with the

old mainboard graphic driver then delete everythings that start with AMD and ATI at the

program files and Regedit , reinstall the driver again and now its working fine, plan to

update the driver very soon, thanks blade061188, your tactics really work !!

m
0
l
Related resources
June 6, 2012 5:29:41 PM

Install the latest version of Microsoft C++ Runtimes for 2005 SP1, 2008 SP1 and 2010 SP1

https://www.microsoft.com/en-us/download/details.aspx?i...

This link will take you to 2005 SP1 x86, but if you look further down you will see links to other versions.

If your an x64 user, install both x86 and x64 versions.

Once installed, reboot and reinstall latest ATI drivers.
m
0
l
June 13, 2012 10:07:31 PM

Best answer selected by cheehieng.
m
0
l
June 10, 2013 2:49:04 PM

I had the same problem. I ended up finding the original DVD that came with the card, and installed the Catalyst Control Center from that DVD. Works fine now.
m
0
l
!