Sign in with
Sign up | Sign in
Your question

GTX 670 Core clock Issues

Last response: in Graphics & Displays
Share
June 7, 2012 7:48:41 PM

Hello, everyone.
I recently purchased a new rig and today I finally got my hands on it. I thought it was going to be awesome, but I was wrong. The problem seems to be the graphics card - the MSI GTX 670 (http://www.newegg.com/Product/Product.aspx?Item=N82E168...) and it's core clock. I know the core clock should be fluctuating between the base and the boost clock, but my card just works in random frequences. When I play Skyrim, for example, at daytime it's almost always 1150 Mhz which is above the boost clock, and at night it's just between 700 and 800 Mhz, which causes lag. I also tried playing modern warfare, which was even worse. In that game, the closts dropped to as much 330 Mhz or something like that, but most of the time it was just 550 Mhz.
Is this normal, what can be done?

This is a printscreen after playing MW3 for a couple of minutes. As you can see, the core clock from time to time jumps to the base clock, however the increase is just temporary.

http://postimage.org/image/b4lz3cdph/
a b U Graphics card
June 7, 2012 8:20:07 PM

It's a driver issue, try using older drivers.

What drivers are you using currently?
June 7, 2012 8:26:29 PM

I have the latest, which should be the 301.42
Ok, so I'll try downloading the R300 driver, which, supposedly, is the previous driver.
Related resources
a b U Graphics card
June 7, 2012 8:29:01 PM

mInInOwA said:
I have the latest, which should be the 301.42
Ok, so I'll try downloading the R300 driver, which, supposedly, is the previous driver.


ye try 301.34
June 7, 2012 9:02:52 PM

Ok, downgraded my drivers, but the problem persists - I'm still getting weird clock, right now I'm running 660Mhz at Markath @ 54 FPS. And the temps should alos be a lot higer, I mean, this card should be around 80s, however I've never seen it go past 72, something's not right.
Any idea what else could it be?
a c 92 U Graphics card
June 7, 2012 9:20:47 PM

can you check the temperatures?
June 7, 2012 9:31:06 PM

Right now, the PC's running 3DMark11, I'll post the score and maximum temperature, when it's done, which should be in a few minutes.
June 7, 2012 9:38:08 PM

Results are here http://3dmark.com/3dm11/3605170 Max GPU temperature registered was 77, which seems kinda weird, knowing the fact that this card should run a bit hotter.
What do you reckon, should I RMA the card?
a c 92 U Graphics card
June 7, 2012 9:40:06 PM

try running the test with fan set at max. but it looks like a faulty card.
June 7, 2012 9:45:16 PM

Anonymous said:
if you care to, try manually adjusting it with precisionX
http://www.evga.com/precision/

Thanks for the advice, but no thanks. I really don't want to fiddle with the card, as I fear of the situation when the card swap is refused because I've changed something. From where I am, human rights aren't assa protected as they are in the States.
June 7, 2012 9:48:08 PM

Anyway, just played Skyrim, while monitoring the Voltage and instead of boosting it, the card undervolts itself, I just don't understand why is this happening ;(
Anonymous
a c 117 U Graphics card
June 7, 2012 9:53:26 PM

i wasn't suggesting you overclock/volt the card. just set it on default to see if it makes a difference.
msi has afterburner
http://event.msi.com/vga/afterburner/download.htm
but i find precisionX easier.

if you feel that the customer support from MSI would be different if you use their supported software because of the country you live in; well i guess that severely limits the options here and just go for an RMA.
June 7, 2012 9:55:42 PM

mInInOwA said:
Anyway, just played Skyrim, while monitoring the Voltage and instead of boosting it, the card undervolts itself, I just don't understand why is this happening ;(


I had the exact same problem with my Gigabyte gtx670, I rma'd it and now everything runs great. It's just a faulty card IMO.
June 7, 2012 10:20:30 PM

Ok, set the fan speed to 60. In skyrim menu the core clock is 324 Mhz and voltage 0.987V, managed to get it up to 1137 Mhz at 1.162V. The boost does turn on, it's just really random and most of the time it's under the base clock. Could it be because it's maxing out 60 fps, thus throttling itself down?
June 7, 2012 10:28:09 PM

mInInOwA said:
Ok, set the fan speed to 60. In skyrim menu the core clock is 324 Mhz and voltage 0.987V, managed to get it up to 1137 Mhz at 1.162V. The boost does turn on, it's just really random and most of the time it's under the base clock. Could it be because it's maxing out 60 fps, thus throttling itself down?


Do you have any stuttering issues, does the screen black out for a second before that?.
June 7, 2012 10:36:06 PM

IvanTheTerrible84 said:
Do you have any stuttering issues, does the screen black out for a second before that?.

Well, it did stutter in Markath, but no black screens. Does your card's clock drop below it's base clock?
June 7, 2012 10:50:45 PM

mInInOwA said:
Well, it did stutter in Markath, but no black screens. Does your card's clock drop below it's base clock?


Yeah, the voltage would drop to 0.987 volt while running games and benchmarks and the base clock will go to about 700 mhz. I tested the card in 3d mark and while the card usually got P9500 when working well it would drop to around 4500 when the voltage dropped.
June 7, 2012 11:27:23 PM

Just simply install or reinstall the 301.42 driver on the Express (recommend) option nothing spectacular and use gpu-z's render test found via the blue question mark (?) to the right of Bus Interface on the first page (graphics card tab) to monitor the max Core clock for the correct performance. Try an see if this works this solved my similar problem with my gtx 460!
June 8, 2012 12:42:19 AM

What your PSU?Turn vsync off.Was the card OC?Also set power target to max.
June 8, 2012 8:34:35 PM

PSU -OCZ Modxstream pro 600W
I was just playing Dirt showown - all settings set to ultra, 4xMSAA @ 1080p and the temperature got to a 100 degrees, that was the moment i tapped alt+F4 and closed the game. I mean, even at the fan speed set to 100%, the card couldn't cool itself and reached the 100 degrees mark. after that I set the settings to high and the card doesn't even reach 70. The card is factory OC to 1045, but it the actual load frequency is 1150 Mhz, which could be causing the problem.
a c 535 U Graphics card
June 8, 2012 8:46:15 PM

Time to RMA your card. It should never get to 100c load temperatures under any circumstances. The erratic clock speeds, which go below the 3D clocks could be a driver problem, but in this case it is clear you have a defective board.
June 8, 2012 9:42:37 PM

Ok, updated the driver to the newest and now the temps didn't even pass the 80 degree mark , leveling out at 75 @ ultra. It seems that it was only a driver issue, because the temps have droped by aproximately 25% wthout any impact on the overall performance (I'm still maxing out at 60fps). Could this all just be a driver issue, because now it's definately fixed.
June 8, 2012 11:28:34 PM

Turn vsync off in all games and check clock.
Anonymous
a c 117 U Graphics card
June 8, 2012 11:32:05 PM

looks like the OP figured it out, after the community rallied around and supported their efforts.
a c 535 U Graphics card
June 8, 2012 11:43:30 PM

mInInOwA said:
Ok, updated the driver to the newest and now the temps didn't even pass the 80 degree mark , leveling out at 75 @ ultra. It seems that it was only a driver issue, because the temps have droped by aproximately 25% wthout any impact on the overall performance (I'm still maxing out at 60fps). Could this all just be a driver issue, because now it's definately fixed.

It looks like it was a driver installation issue after all. If the problem comes back, completely restart your PC and see if that fixes the problem. This is an issue with the 300 series and above drivers. You can also try to set the Power Management setting in the Nvidia Control Panel to "Prefer Maximum Performance", which has been reported to fix the problem as well.
August 5, 2012 12:53:48 AM

IvanTheTerrible84 said:
Do you have any stuttering issues, does the screen black out for a second before that?.


I have exactly this problem, smooth playing, then black screen for a second and major FPS drop, any suggestions?
August 19, 2012 4:00:13 AM

I'm having this problem as well, and it is an MSI card. That's what I get for not going with the EVGA FTW series. I'm going to do a driver wipe, but I don't expect it to resolve this issue.

My 3DMark 11 score shows 700mhz as well:

http://www.3dmark.com/3dm11/3605170

I'll post again soon if the driver wipe/reinstall resolves this issue. Is there any modern driversweeper program?
August 20, 2012 6:15:50 PM

I managed to fix this by changing the power management value in NV control panel.
January 25, 2013 1:32:12 PM

there is even a way to get more higher performance:

connect both hdmi output`s to one screen.
it is also possible to connect using vga and hdmi output .
this will give screen 1/2 and screen 2/2 in control panel now cole these 2 screens.
in nvidea inspector 1.9.9 there is a option multimonitor mode .
set multi mon extended single mon.
take notice @ the temp after reboot cause your gpu should get a little hotter
also.
another performance boost is scaling setting native resolution in windows and then go to desktop size and position in nv control panel.
you can set resolution forced to 1280x768P anything above 768 is 1080P
now scale to full screen using display and you playing a kind of cropped version of 1080P
advantages is no lag i archieve 203 fps in crysis 2 maxed out using 480P to full screen and increase of level of detail(LOD)with i3 and gtx480
April 29, 2013 7:56:39 AM

mInInOwA said:
Anyway, just played Skyrim, while monitoring the Voltage and instead of boosting it, the card undervolts itself, I just don't understand why is this happening ;(


the kelper chips underclock themselves if they reach a temp of 70c also another thing that can mess with your clocks are...if you are playing a games that does not demand the full potential of the card itself and thus will downclock the frequency
!