Sign in with
Sign up | Sign in
Your question

Gtx 670 owners!! asus Gtx 670 performing poor in crysis 2

Last response: in Graphics & Displays
Share
a b Î Nvidia
June 9, 2012 10:50:13 AM

I have the gtx670 direct cu ii top edition and its a helluva performer. Awesome 3dmark results and performing excellent in metro2033 and battlefield3..(with overclocking this card gets 80+ fps most of the time in bf3 mp maxed out at 1080p)-battlefield 3 runs smooth as a cupcake.

The only problem so far is- Crysis2

The card is performing horribly-even worse than my gtx580. Fps between 40-60 at ultra 1080p and sometimes going as low as 29fps, there is lags and the gameplay in general is not smooth. The funny thing is even when I lower the settings- the fps still drops occasionally. The max fps goes up to 109 but the drops are still there. I tried turning on the vsync but that didn't help.

So my question to the gtx670 owners is- are you having similar problems in that game. I have the latest 300.42 drivers. And I am talking about the multiplayer gameplay of crysis 2. Perhaps its a driver issue and the next nvidia driver will fix it?
a b Î Nvidia
June 9, 2012 10:59:22 AM

It might be your CPU, what do you have? What's your resolution?
a b Î Nvidia
June 9, 2012 11:03:29 AM

Sunius said:
It might be your CPU, what do you have? What's your resolution?


i5 760 running at 3.8-4.0ghz. I like to switch around. But yeah maybe my settings aren't too stable. It passed 6 hours of prime95 though couldn't be bothered running the test for longer period. I play at 1920x1080.

currently my i5 760 is overclocked at 180x21 with 1.425 vcore. Idk if its stable for sure.
Related resources
June 9, 2012 11:38:40 AM

try with older driver version see if anything change, but i guess something is going wrong with the game, reinstall it?
a b Î Nvidia
June 9, 2012 12:13:45 PM

xtreme5 said:
try with older driver version see if anything change, but i guess something is going wrong with the game, reinstall it?


I doubt it I purchased the game on origin so its hard to reinstall, also my dl speed is limited to 370kbps
June 9, 2012 12:40:05 PM

hmm, did you try with old driver v.
a b Î Nvidia
June 9, 2012 2:19:57 PM

xtreme5 said:
hmm, did you try with old driver v.


rolled the driver back to the original 300.25. started a new game single player. The fps was around 40-60 mostly around 48-49. Is that normal?

Then started a new multiplayer game. It was smoother than ever. Consistant 68-90fps never dropping below 60. Then started the 3rd game.This time the fps stayed in the 40s, sometimes jumping to the 50s but the gameplay was not as smooth as the previous game. And It was the same map and same players were in it. I am surprised about this unusual behaviour. And this whole time I was monitoring thru msi afterburner, I saw consistant 99% gpu usage with gpu boost upto 1313mhz. This is quite puzzling for me! :( 
June 9, 2012 3:37:00 PM

I am having a similar issue with BF3 did you have any problems with that game?
a b Î Nvidia
June 9, 2012 3:52:11 PM

euansharp said:
I am having a similar issue with BF3 did you have any problems with that game?


nope surprisingly bf3 runs flawlessly...whats with this inconsistent behaviours of these gpus?
June 11, 2012 1:22:27 PM

Hmm....not having any issues with the card. Although I haven't given Crysis 2 a shot so far. Everything else is going great. I'll run the single player for a bit and report in.
a b Î Nvidia
June 11, 2012 1:39:48 PM

namelessonez said:
Hmm....not having any issues with the card. Although I haven't given Crysis 2 a shot so far. Everything else is going great. I'll run the single player for a bit and report in.


thanks that'd be great since our systems are identical, we have the exact same cpu and gpu.
June 11, 2012 1:52:57 PM

Sure thing, will give it a shot as soon as I get home from work.
June 11, 2012 8:50:14 PM

It could be VSync. I was getting some terrible stuttering with Crysis 2 (BF3 runs like a champ at 1080p ultra), but then I turned of Vsync in the in-game control panel and it runs smooth as butter now!

also, for reference, I'm running an I5 2500K at stock speed with 16GB RAM
June 11, 2012 11:09:18 PM

I got the same problem and it happens when I play Crysis 2 hmmm strange!!
June 12, 2012 12:40:58 AM

I believe it's game specific and related to the nividia drivers, turning of vsync helped in BF3 but I found I could get the best fps out of it if I keep aa to a minimum. My rig is an i52500k with 8Gb RAM. the fps still fluctuates like crazy but now it's more or less playable. Afterburner shows really low gpu usage while BF3 is on yet the card champs in heaven very strange indeed. DICE or Nividia really need to fix this. Oh well tribes and wigeon for now hope they fix this before planetside 2 beta looking forward to that.
June 12, 2012 10:49:48 AM

shamsmu said:
thanks that'd be great since our systems are identical, we have the exact same cpu and gpu.

Ok, I gave it a go. FPS was between 65-75 (fluctuating, not stable). That was with 'motion blur' turned off. When I turned motion blur on, it would range between 55-70 but occasionally touch 50. So maybe its the motion blur which is causing the problem? For me, it was definitely better off without motion blur. Never noticed it because I never really had motion blur turned on coz I like a smooth play without the hazy effects while turning in-game. Oh, and I kept v-sync off.

That apart, a steady 65-75 with everything on highest. Give it a try and see if it works out the same way for you. Let me know how it goes.
June 12, 2012 11:38:57 AM

namelessonez said:
Ok, I gave it a go. FPS was between 65-75 (fluctuating, not stable). That was with 'motion blur' turned off. When I turned motion blur on, it would range between 55-70 but occasionally touch 50. So maybe its the motion blur which is causing the problem? For me, it was definitely better off without motion blur. Never noticed it because I never really had motion blur turned on coz I like a smooth play without the hazy effects while turning in-game. Oh, and I kept v-sync off.

That apart, a steady 65-75 with everything on highest. Give it a try and see if it works out the same way for you. Let me know how it goes.

Dude ur 670 is OC.Try running at stock setting.
a b Î Nvidia
June 12, 2012 1:27:29 PM

namelessonez said:
Ok, I gave it a go. FPS was between 65-75 (fluctuating, not stable). That was with 'motion blur' turned off. When I turned motion blur on, it would range between 55-70 but occasionally touch 50. So maybe its the motion blur which is causing the problem? For me, it was definitely better off without motion blur. Never noticed it because I never really had motion blur turned on coz I like a smooth play without the hazy effects while turning in-game. Oh, and I kept v-sync off.

That apart, a steady 65-75 with everything on highest. Give it a try and see if it works out the same way for you. Let me know how it goes.


turned off motion blur and you are right it was definitely better, 65-90fps most of the times in the first game of mp. Then on the 2nd game the fps stayed 55+..however, during the enemy gamma burst attack, the fps went down to 20, stayed in the 30s for four seconds. I just realised the fps drops mostly when there are gamma bursts and seth gunships around. But turning off motion blur definitely increased the fps by 10-15. Thanks for the intel.
June 12, 2012 1:36:20 PM

shamsmu said:
turned off motion blur and you are right it was definitely better, 65-90fps most of the times in the first game of mp. Then on the 2nd game the fps stayed 55+..however, during the enemy gamma burst attack, the fps went down to 20, stayed in the 30s for four seconds. I just realised the fps drops mostly when there are gamma bursts and seth gunships around. But turning off motion blur definitely increased the fps by 10-15. Thanks for the intel.

Glad it helped! Enjoy!!
June 14, 2012 12:59:53 PM

Crysis 2 was doing this for me to with my 670 OC windforce. I OC'd it to achieve a max boost of 1360 which was stable on everything else. but it was causing this very issue only in crysis 2. i dropped my OC with +150core and +500 vram and now's it gone and im boosting to 1310.

so.. if you're OCing try lowering it a tad.
!